Electronic Display Failure

This is a discussion on Electronic Display Failure within the Evoque Maintenance forums, part of the Land Rover Evoque Garage category; Got my Evoque 9 months ago. I have had display problems intermittently every month. I will start the engine and when the display comes up ...

+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Junior Member
    Member #
    997
    Join Date
    Sep 2012
    Posts
    3

    Electronic Display Failure

    Got my Evoque 9 months ago. I have had display problems intermittently every month. I will start the engine and when the display comes up the Audio/Video segment is greyed out, not functional. The Nav & Phone segments are lit but not functional as in I can select Nav and it will go to the agree statement which I select agree and it moves to the "initializing" segment and will not move beyond that segment. When I select the Phone option nothing happens beyond it saying "please pair phone". The first several times this happened the display would start working after the engine was shut off overnight but this last time it shut off 2 weeks ago and will not come back on. I have tried disconnecting/reconnecting battery cables, disconnecting just the ground cable. Checked fuse. Disabled bluetooth on phone also doesn't help. Backup camera does work but I have no sound with it. All buttons on the left side of display work: Setup, System etc, I can adjust clock etc. but I have no functions from right side buttons of display. Then yesterday when I tried to start the engine a notice said "smart key not found" well I did have smart key, thats how I got in! Held smart key in my hand and tried to start engine "smart key not found" again. So I hit the unlock button on the smart key remote and I heard the clicking of the doors unlocking and wha-la the engine starts. I happen to live 450 miles from my dealer/service dept so I would like some assurance they have an idea of what to do to fix the issue but after speaking with them several times they have no clue. I just live too far for them to tell me to just "drop by" so they can "reset" the computer. So am I looking at a 450 mile drive without audio, a day to diagnose problem, a day or 3 to order & get parts & a day to fix problem and then 450 mile drive home? I have been waiting 3 days for a call back from Land Rover. Any and all advice would be greatly appreciated.

  2. # ADS
    Ads


  3. #2
    Member
    Member #
    716
    Join Date
    Jun 2012
    Location
    Stamford, CT
    Posts
    90
    It sounds like you've got a bad Nav/Entertainment center computer module and/or associated wiring connections. Most of the functions you mentioned having issues with are controlled through that module. Demand they replace that computer module and see if they have or can order a replacement for you ahead of you going out there as it could take days or even weeks to get one shipped to them. Most dealers will not be so accommodating as they require diagnosing the issue first before placing any replacement part orders they don't already have in stock. But you better ask as that will be the decision point on whether you make the trip. And you may want to plan on staying overnight once you do to allow the service department that few extra hours of testing time.

    I don't know where you live but you might want to reconsider buying any new vehicle, epecially a first year, brand new model like the Evoque, where you don't have a service department somewhat close to you. You've basically thrown away the use of most of the 4 year/50K mile warranty value down the drain because you don't live within range to take advantage of it.

  4. #3
    Junior Member
    Member #
    997
    Join Date
    Sep 2012
    Posts
    3
    So after speaking with service dept and describing display problems they "speculated" the audio module was malfuncting. I requested they have this replacement part on hand when I arrived for my service appointment. They would not do this until they could positivly diagnose the problem. I made the 8 hour drive and upon arriving at the service dept it took a total of 1 hour for them to arrive at the conculsion of a....surprise....audio module malfunction..what a shocker! Now for the real upsetting news..the audio module is not a part that is kept stocked in service departments in the U.S. It is also not a part that is kept stocked in service departments in the U.K. This is a part that has to be taken off of the assemble line and at this point they can not even give me an estimate of when they can give me an estimate when they will be able to get the part off of the assemble line. Which when they actually do get the part it will be sent to the U.S via boat...yeah, boat. Not airplane but boat. Seriously!

  5. #4
    Junior Member
    Member #
    997
    Join Date
    Sep 2012
    Posts
    3
    Believe me I did consider the drawbacks of buying a new Evoque for all of the reasons Evogoon stated. On Valentines Day my husband took me for a drive. 450 miles later, with no hints, we pulled into the Land Rover dealership and it is sitting in front with a big red bow on top. He is an excellant mechanic who not only restores cars but airplanes as well. He was very sceptical of Land Rovers reliability reputation but in spite of that went ahead. I guess he let his heart overrule his head.

  6. #5
    Junior Member
    Member #
    1136
    Join Date
    Nov 2012
    Posts
    2
    Even i have land rover discovery...Did you check your battery connection and other wires connected to the battery...... due to loose conection this can happen... Even i am facing similar sort of problem... lights are not being on........ i checked but could not find the solution.. i have checked battery but its not dead.. then what can be the problem. any idea guys????
    Last edited by DavidWilliam; 11-14-2012 at 09:11 AM.

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. iPod Connection - Display Stalling - Anyone else?? HELP
    By EvoVan in forum Evoque Maintenance
    Replies: 14
    Last Post: 09-24-2012, 03:30 PM

Search tags for this page

evoque navigation module
,

evoque navigation screen system initializing

,
how to fix range rover evoques screen
,
range rover evoque smart key not found
,
reset smart key in range rover evoque
,
screen not working range rover evoque
,

smart key not found on range rover evoque

,

smart key not found range rover

Click on a term to search for related topics.
Find us on Google+

SEO by vBSEO ©2011, Crawlability, Inc.