After Two Months.....

After Two Months.....

This is a discussion on After Two Months..... within the Evoque Forum forums, part of the Evoque Discussions category; I'm not real happy. I purchased a 2013 Evoque Pure Plus Santorini Black. I wanted black wheels but they did not have any at the ...

Results 1 to 8 of 8
  1. #1
    Junior Member
    Member #
    1755
    Join Date
    May 2013
    Location
    Jonesboro, AR
    Posts
    4

    After Two Months.....

    I'm not real happy. I purchased a 2013 Evoque Pure Plus Santorini Black. I wanted black wheels but they did not have any at the dealership but they did have an after market company they use to paint the wheels black. Here is a picture.

    Name:  Evoque 4.JPG
Views: 701
Size:  57.5 KB

    I was hopeful I wouldn't have to start a thread like this but here goes. Keep in mind that I live a just over an hour from the dealership.

    1. The wheels need to be repainted because they missed some spots. Not a big deal though.

    2. My windshield cracks from a tiny chip at the bottom of the windshield frame. They won't cover it through the warranty no matter how much I complain. This happened exactly 30 days of owning the car and the service advisor agreed it was almost impossible for something to hit it where the chip was.

    3. Eight days ago the TPMS light for the front left tire came on. I put some air in and the light went off. Came back on the next day so I took it to the tire shop thinking I had a slow leak. No leak at all. This goes on and off all week. I call the dealer on Friday and they ask me to come in Saturday morning at 8:00. The night before I put air in the tire again just to be safe. All the way there, and at the dealership, the light doesn't come on. Typical. After two hours they cannot find anything wrong.

    4. The same day on the way back home I punch the accelerator to get around some traffic and I lose power. It feels like half of the engine has shut down, the engine light comes on and a message pops up saying something like "Engine cannot operate at full capacity at this time". This happens on the interstate so I pull over at the next exit, turn it off, and sit there for a couple of minutes, start it back up and it seems fine. I immediately called he service advisor I had just left and he says he's never heard of that before.

    5. The next day I wash the car, start to put it back in the garage ant the TPMS IS BACK ON!!!. I took a picture and sent it along with a nasty email to the salesman, service advisor, service manager, sales manager, and general manager. I basically told them I had reservations on buying a Land Rover based on past history, living an hour from the dealership, and that I couldn't take off work all the time to mess with problems like this on a brand new car.

    At 7:30 they called me this morning and tried to defend the problems with the computer. And I know that's going to be the problem with all cars as technology advances, but I'll take a plain car with a key any day. Anyway, the dealer delivered an Evoque to me at work on a truck and hauled mine back. They are going to keep it for the week and try to take care of everything.

    My wife has an Audi Q5 with no issues and she loves the look of my Evoque. I told her one more problem and the Evoque is hers, I'll take the Audi and eventually trade it in for a Toyota. I drove an FJ Cruiser for six years with no problems other than general maintenance, brakes, battery, and etc... I passed it on to my son. Best car I've ever had.

    Anyone else have similar issues? Advice?
    2013 Evoque Coupe Pure Santorini Black

  2. # ADS
    Ads


  3. #2
    Senior Member
    Member #
    1315
    Join Date
    Jan 2013
    Location
    Malibu CA
    Posts
    373
    Well... first and foremost, your dealer sucks Kraken Dick. When you lost power were you driving in wet weather conditions? Known issue. Tire. You may indeed have a leak. It may be hard to find. Or, you may need to have your TMPS reset. Have you checked your tire with a gauge? The wheels are your problem. All car models can have issues. I have had none with my Evoque and, in fact, it is my families 7th LR product and we have had great luck. We also have a great dealer. On the other hand I have a friend with an Audi Q-something who wants to drive it through the dealer's show room window and emerge with an M-60. Welcome to today.

  4. #3
    Junior Member
    Member #
    1755
    Join Date
    May 2013
    Location
    Jonesboro, AR
    Posts
    4
    Quote Originally Posted by scrannel View Post
    Well... first and foremost, your dealer sucks Kraken Dick. When you lost power were you driving in wet weather conditions? Known issue. Tire. You may indeed have a leak. It may be hard to find. Or, you may need to have your TMPS reset. Have you checked your tire with a gauge? The wheels are your problem. All car models can have issues. I have had none with my Evoque and, in fact, it is my families 7th LR product and we have had great luck. We also have a great dealer. On the other hand I have a friend with an Audi Q-something who wants to drive it through the dealer's show room window and emerge with an M-60. Welcome to today.

    It was wet, raining in fact. They just called me and said I had a small, pin sized hole in the sidewall. No idea how that happened since I treat the car better than my own kids . He gave me the price for a tire of $4020 and I immediately found it on Tire Rack for $261. I'm waiting for him to call back now.

    The sales manager was defensive and talked down to me the whole time we discussed the issues. We have had five BMW's with no issues, a POS Mercedes, a Jag and a Mini. Other than the Mercedes all were fine. To me BMW is the best.

    My wife has an Audi Q5 with no problems at all but she loves the Evoque. I'm probably going to let her have it, drive the Q5 for a bit then get rid of it and go back to a Toyota.
    2013 Evoque Coupe Pure Santorini Black

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Senior Member
    Member #
    328
    Join Date
    Jan 2012
    Location
    Minneapolis, MN
    Posts
    482
    The restrictive performance issue is something all the Evoques potentially have. The dealer knows about it. If they say they don't, they are full of it. There are multiple threads about it in this forum.

    Glad the TMPS was a leak- easier to fix! Bummer you get stuck with the bill.

    I am sorry to say I have been wholly unimpressed with LR service compared to other luxury brands. Oh well- I too was hesitant to buy LR, but was too impressed with the Evoque to pass it up. A year in, and very few issues passed, I am still happy with the decision.



    100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
    2012 Fuji White Evoque Prestige- Tan/Ivory/Espresso Interior, Sport Pedals and Sport Style Foot Rest, Mud Flaps, Silver Rails, OEM Ski Rack and Bike Rack , Climate Package, Style 6 wheels with Hankook tires in summer, Style 5 wheels with Blizzak tires for the frozen Minnesota tundra in winter- Set for Adventure in Style!

  7. #5
    Junior Member
    Member #
    305
    Join Date
    Jan 2012
    Posts
    20
    Quote Originally Posted by astatepat View Post
    4. The same day on the way back home I punch the accelerator to get around some traffic and I lose power. It feels like half of the engine has shut down, the engine light comes on and a message pops up saying something like "Engine cannot operate at full capacity at this time". This happens on the interstate so I pull over at the next exit, turn it off, and sit there for a couple of minutes, start it back up and it seems fine. I immediately called he service advisor I had just left and he says he's never heard of that before.
    This is a known design flaw. Unfortunately a major safety issue and incredibly dangerous (just imagine if you this happened as you were passing on a one lane road or if you were turning left at a light with oncoming traffic...at least noone's died yet from this, not to my knowledge). My advice to you would be to get rid of your Evoque ASAP. They have a 'software patch' and a 'hardware screen patch' which supposedly is a "WORKAROUND" to stop this from happening, but nevertheless the design flaw is still there. I would not risk the safety of my children in this vehicle. The problem is across the entire fleet of Evoques. You can follow the exact details of the problems and "supposed fix" in this thread: https://www.evoqueforums.net/forum/ev...-bulletin.html The only official letter I've seen from LR is here: http://www-odi.nhtsa.dot.gov/acms/cs/jaxrs/download/doc/UCM434614/CSC-10051512-3725.pdf Another site forum talking about this here (again, this is a widespread problem): http://babyrr.com/forum/thread-4955.html

    To sum up the problem the design flaw is with condensation build up in the inter-cooler that when the Turbocharger kicks on it blasts a shot of air through here that blows the condensation off onto something that shorts out and causes the cylinders to misfire and trips the car into LIMP mode. Their software patch makes the car run on 3 cylinders when this happens instead of disabling the entire engine. The hardware patch is a screen install somewhere in there to try and stop the water causing the short. It's totally crap. I wouldn't trust it. It's a workaround as opposed to a real fix for the condensation build up. Sorry to be the bearer of bad news.

    Oh and by the way, the service technician was lying to you. This problem has been around from day 1 of the Evoques being delivered back in Nov `11. Every single service tech knows this. They just didn't want you to make a big stink about it. A majority of people having this problem got rid of their Evoques due to this design flaw.
    Last edited by yobigd20; 06-10-2013 at 04:41 AM.

  8. #6
    Senior Member
    Member #
    1315
    Join Date
    Jan 2013
    Location
    Malibu CA
    Posts
    373
    Quote Originally Posted by yobigd20 View Post
    A majority of people having this problem got rid of their Evoques due to this design flaw.
    Oh, really? You can document this? The screen fix is supposed to work, BTW. But, you need a dealer who is more helpful, or who can be made to be more helpful.

  9. #7
    Junior Member
    Member #
    1755
    Join Date
    May 2013
    Location
    Jonesboro, AR
    Posts
    4
    Thanks yobigd20. I saved the copy of the letter.

    I live an hour away from the dealership and they brought me a loaner to work. They kept the car for exactly two weeks and it seems to be okay. What really gets me though is the way the dealership talked down to me and wouldn't pay for the tire and windshield after only 30 days. I'm now in this evil circle of surveys and follow up calls. The latest being yesterday when I just verbally raped the Land Rover America rep. I told them that for the type of money I spent on the car, two weeks in the shop, and the costs I've incurred in 30 days of ownership they should pay. She really didn't know what to do after I blasted her.

    My wife loves the car so I gave it to her and bought a Toyota Tacoma truck and couldn't be happier. I have a real key now and if I'm in a hurry I don't get the "key not detected " message from Toyota because I have a REAL key. Hell, they even sent me some really tasty cookies for buying a new truck. The dealership is great and even turned my seat belt chime off for me. All I got from Bluff City Land Rover was a $2,000 bill after keeping my car for two weeks.

    Live and learn.
    2013 Evoque Coupe Pure Santorini Black

  10. #8
    Member
    Member #
    1250
    Join Date
    Dec 2012
    Location
    South Jersey
    Posts
    95
    Sorry about your experience with the car...we've been Blessed with ours thus far. I'm curious about what the real fix should be for this condensation issue though...I'm afraid that one will rear its head and I'd rather be proactive and put something on to prevent it.

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. wts our 4 months used 2012 Range Rover Evoque
    By autosan in forum Evoque Classifieds
    Replies: 0
    Last Post: 05-07-2013, 12:36 AM

Search tags for this page

evoque problems and flaws

Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.