2014 evoque, one month old and multiple issues

2014 evoque, one month old and multiple issues

This is a discussion on 2014 evoque, one month old and multiple issues within the Evoque Forum forums, part of the Evoque Discussions category; Bought a brand new 2014 Evoque from BUDD's Range Rover in Ontario... the issues started in the first week... 1. Gear shifter would go up ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Like Tree2Likes

Thread: 2014 evoque, one month old and multiple issues

  1. #1
    Junior Member
    Member #
    6438
    Join Date
    Mar 2014
    Posts
    5

    2014 evoque, one month old and multiple issues

    Bought a brand new 2014 Evoque from BUDD's Range Rover in Ontario... the issues started in the first week...

    1. Gear shifter would go up and down multiple times and then stay in the down position when starting the vehicle. I would have to restart the vehicle at least three times before it would stay up.
    I called the dealership and they said "unless it gets stuck down there is nothing we can do" - not impressed with this response

    2. Check Coolant warning message would appear
    I called the dealership again and they said "this is normal when it is cold outside, even if the vehicle is store in a garage..." once again, not impressed

    3. Weird noise coming from the underside of the vehicle, sounds like a pump turning on and off constantly
    This was my breaking point, I demanded to bring the car in for a check up this was just getting ridicules, I couldn't bring in the car right away as I was leaving for a business trip so I made the appointment for a week later when I would be in town.

    The dealership sent someone to pick up my car, I explained to him the noise and asked him to drive it with the radio off and listen for the noise. He heard it almost instantly after leaving me.
    Once at the dealership, the first issue was fixed by a software upgrade... why didn't they loaded the newest software on the car before selling it to me?!
    The mechanic could not replicate the sound while on his test drive, so they decided to just return the vehicle to me. Well the same person who picked up my evoque was driving it back to me, and surprise surprise! He heard the sound again so phoned me and asked me what I wanted him to do, obviously I did not want it back if the issue wasn't fixed so back to the dealership it went. Well 5 days later and they believe they found and fixed the issue, apparently the hydraulic pump was missing a bushing and some piece was just bolted to the body of my vehicle.. apparently a mistake made at the factory.

    Well sure enough, the next time I drove the vehicle I heard the sound again! this time I was not going to mess around so I recorded the noise, yes it is that loud that i could record it from my phone while driving! This happened on a Friday and they could not take my truck until Monday and what happened on Saturday?! Well the check engine light came on of course and while I was idling at a light the car would shake excessively. I had finally reached my destination and after having the car off for a few hours when I turned it back on the check engine light was off.

    So Monday, it went back to the shop and it has been there over a week, the mechanics are stumped. They have no clue what is causing this noise. They have replaced the whole hydraulic pump and hose and the noise is still there, just not as loud (This is what they say, but I have not heard it for myself). Now we are waiting for "the engineers to come inspect the car" but they have to stop off in New York before arriving in Toronto.

    They provided me with a loaner vehicle, a 2013 evoque that had 10,000km and guess what, the night headlights did not work! It was an interesting drive home on the why that I use that has no street lights! Thank god for the vehicle in front of me that I followed because all I had was the daytime running lights. The high beams did not work as well! So called the dealership again and they came and swapped the truck out for an LR2.

    Like REALLY?! This car is 6 weeks old, and has been in the shop for 3 weeks. This is not OK?! Has anyone else had these issues? Is it normal that they have to fly someone in the figure out what is wrong with the car?

    I'm really starting to regret buying a range rover, I know they are known to have issues but I just loved the Evoque so much and took the chance. I'm having buyers remorse... and I'm not paying what I pay a month for this vehicle to be driving a basic model 2011 LR2... not happy... not happy at all

  2. # ADS
    Ads


  3. #2
    Senior Member
    Member #
    3512
    Join Date
    Dec 2013
    Location
    Richmond, Texas
    Posts
    518
    Ok first of all...Budd's?
    Start documenting just in case you need to use the lemon law, do you have something similar in Canada?

    So far I haven't seen anything on 2 forums like the pump noise you're describing. I think I saw something here on the shifter not coming up. Did you get a reduced engine performance message when it was on idling real rough?

    My check engine light comes on intermittently & it's throwing a fuel pressure regulator code but it runs fine. Otherwise no issues at 32,000 miles.

    Headlights are single element so if lows are out so are the highs.
    Last edited by Rovingvic; 03-19-2014 at 09:37 AM.
    You shouldn't have to stop just because the pavement does! 2012 Range Rover Evoque Pure Plus Coupe, 2009 Land Rover LR2 HSE traded, 2008 Land Rover LR2 SE traded.

  4. #3
    Member
    Member #
    2252
    Join Date
    Aug 2013
    Posts
    74
    Sounds like it is time to get the home office of Land Rover involved, seeing as how you are having issues with how the dealer has responded as well as the vehicle itself. I mean, how you get a vehicle handed over without the latest updates is kind of startling to me.

    The coolant issue sounds like that described in this thread, which again is a known issue that can be solved by the dealer.

    also - have you registered on TOPIx and run your VIN to see if there are outstanding maintenance campaigns?
    Delivered! MY2014 Pure Plus, Firenze Red w/ Cirrus/Lunar interior, Climate Comfort & Vision Assist packages

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Junior Member
    Member #
    2178
    Join Date
    Aug 2013
    Location
    Saint Paul, MN
    Posts
    21
    Sorry to hear about your troubles! You should probably ask to talk to your local LR dealer's service manager about your troubles. Hopefully they can figure out what the issue is and fix it for good. If they can't, you can try to get your dealer to buy the Evoque back or see if you can force them under your local lemon laws.

  7. #5
    Junior Member
    Member #
    6438
    Join Date
    Mar 2014
    Posts
    5
    So turns out my vehicle is one in 4 that have this issue in north america that they are currently still trying to figure out what it is exactly causing this noise... crushed... at least they are providing me with a loaner vehicle at no cost until they figure it out. And then, depending on how long my car has been in the shop will be compensating me an unknown amount

  8. #6
    Super Moderator
    Member #
    1235
    Join Date
    Dec 2012
    Location
    Canal Fulton, Ohio
    Posts
    526
    Glad to hear that your dealer and Land Rover are working to solve your problems. This is as it should be, but unfortunately, not always the case.

    Please keep us posted as to what they find out. Hopefully it won't be anything serious.

    Good luck!

  9. #7
    Member
    Member #
    4008
    Join Date
    Jan 2014
    Posts
    76
    My 2014 has no issues so far, but I've only got 2500 miles.

    There is an odd thing that happens however. Sometimes after I start the vehicle, the engine makes a very weird alien sound...like a robot voice. It's hard to explain, but it usually goes away after a couple minutes.

  10. #8
    Junior Member
    Member #
    5547
    Join Date
    Feb 2014
    Posts
    1
    Engineer - perhaps your Evoque is a Transformer
    tomkosola and Fofomon like this.

  11. #9
    Junior Member
    Member #
    6438
    Join Date
    Mar 2014
    Posts
    5
    that would be AMAZING!

  12. #10
    Junior Member
    Member #
    6667
    Join Date
    Apr 2014
    Posts
    2
    Oh man... I am supposed to be taking delivery of my new Dynamic next week and reading about your troubles makes me nervous! I purchased from Grand Touring Autos in Toronto.

    Sorry to hear all you've gone through. After paying $70k for a car, I would not want to own the one that has problems like this right off the bat, even if they fix it.

Page 1 of 2 1 2 LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 2014 Evoque availability in US?
    By Gg2 in forum Evoque Purchasing
    Replies: 26
    Last Post: 03-24-2014, 05:54 PM
  2. after 4 month driving..
    By prana in forum Evoque Forum
    Replies: 3
    Last Post: 06-02-2013, 01:25 AM
  3. Replies: 3
    Last Post: 02-17-2013, 09:14 AM
  4. Anyone going to the Historics next month?
    By rdwarur in forum Evoque Forum
    Replies: 0
    Last Post: 07-19-2012, 06:39 PM
  5. January 2012 - Evoque of the Month Contest!
    By dascrow in forum Evoque News
    Replies: 3
    Last Post: 01-21-2012, 08:21 AM

Search tags for this page

2014 evoque problems
,

2014 range rover evoque problems

,
evoque check engine off when started
,
evoque issues
,

evoque problems

,
problems with 2014 evoque
,

range rover evoque common problems

,
range rover evoque shifter goes up and then back down
Click on a term to search for related topics.

Tags for this Thread

Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.