Rusty Wheel Hubs: Anyone else having this issue?

Rusty Wheel Hubs: Anyone else having this issue?

This is a discussion on Rusty Wheel Hubs: Anyone else having this issue? within the Evoque Forum forums, part of the Evoque Discussions category; The wheel hubs on all four corners are rusting and throwing "rusty water" onto my rims. Now I can understand the typical rust that forms ...

Results 1 to 5 of 5
  1. #1
    Junior Member
    Member #
    6773
    Join Date
    May 2014
    Posts
    8

    Rusty Wheel Hubs: Anyone else having this issue?

    The wheel hubs on all four corners are rusting and throwing "rusty water" onto my rims. Now I can understand the typical rust that forms on the rotor surface when the car has sit, and then gets worn off by the brake pads.

    This however, is forming on the "hub" and is enough to cause that "rusty water spray" onto my rims.

    Anyone else have this problem? Is this supposed to be acceptable by customers? (is is a 2014 which I bought back in May of this year)

    I don't find it acceptable........none of my other cars have done this over the years, just the Evoque.

    Thoughts?
    Attached Images Attached Images  

  2. # ADS
    Ads


  3. #2
    Senior Member
    Member #
    1903
    Join Date
    Jul 2013
    Posts
    242
    The rims are aftermarket?

  4. #3
    Junior Member
    Member #
    6773
    Join Date
    May 2014
    Posts
    8
    Quote Originally Posted by mstraka View Post
    The rims are aftermarket?
    Yes. Aftermarket replicas of the factory Style 6. I had them completely powder coated in black.

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Senior Member
    Member #
    6891
    Join Date
    Jul 2014
    Posts
    173
    Heard about it happening on other vehicles but not fun to see on your own. Maybe clean and paint them? Powder coating would be an option but probably more $$ than it's worth.

  7. #5
    Junior Member
    Member #
    6943
    Join Date
    Aug 2014
    Posts
    14
    I would hit them really well with a wire brush and just paint with primer.

    JDiehl

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. (Video) Anyone seen this issue?
    By CB17 in forum Evoque Media
    Replies: 3
    Last Post: 09-25-2014, 07:07 PM
  2. Issue with new 9 speed transmission?
    By hjt113 in forum Evoque Forum
    Replies: 2
    Last Post: 07-03-2014, 05:01 PM
  3. Alignment issue
    By Evocurious in forum Evoque Maintenance
    Replies: 1
    Last Post: 11-11-2012, 02:38 PM
  4. Parkin brake issue
    By WatchgeekLdibari in forum Evoque Maintenance
    Replies: 1
    Last Post: 08-03-2012, 12:12 PM
  5. Paint Issue
    By WatchgeekLdibari in forum Evoque Forum
    Replies: 3
    Last Post: 07-08-2012, 11:56 PM

Search tags for this page

rusty wheel hubs problem

Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.