jerky acceleration

jerky acceleration

This is a discussion on jerky acceleration within the Evoque Forum forums, part of the Evoque Discussions category; I have recently noticed that my car is very jerky while accelerating. At higher speeds such as on the highway it doesn't do it very ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    Member
    Member #
    1420
    Join Date
    Feb 2013
    Posts
    49

    jerky acceleration

    I have recently noticed that my car is very jerky while accelerating. At higher speeds such as on the highway it doesn't do it very often, but when I go start it up and take off it is very jerky. Same thing happens when I stop at lights or a stop sign. is Evoque 2012 39000 mile. do anybody know is that normal
    Thanks

  2. # ADS
    Ads


  3. #2
    Senior Member
    Member #
    3512
    Join Date
    Dec 2013
    Location
    Richmond, Texas
    Posts
    518
    I say no, it's not normal. Take it in for service while it's still under warranty.
    You shouldn't have to stop just because the pavement does! 2012 Range Rover Evoque Pure Plus Coupe, 2009 Land Rover LR2 HSE traded, 2008 Land Rover LR2 SE traded.

  4. #3
    Member
    Member #
    1420
    Join Date
    Feb 2013
    Posts
    49
    i have appoitment next Saturday. i believe LR will say "could not duplicate at thise time"

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Senior Member
    Member #
    7080
    Join Date
    Sep 2014
    Posts
    335
    First thing you need to pay attention to is does it feel motor or tranny related?

  7. #5
    Member
    Member #
    1420
    Join Date
    Feb 2013
    Posts
    49
    i don’t know i assume is engine. when i drive and try to accelerate i fill in the seat car hesitate to pull bat stay in the same gear, on highway at 70 mph on cruise if i come to slow incline i filling car hesitate to maintain speed . feels like engine misfire .

  8. #6
    Senior Member
    Member #
    7080
    Join Date
    Sep 2014
    Posts
    335
    Does sound like a misfire, a faulty MAF or leak in intake which would cause a balky , misfire. A bad coil would just be a shuddering dead feeling (truly down on power). Maybe wyou got some gas with water in it. That could also do it. Doesn't sound unlike the limp mode I experienced last month in heavy rain. Couldn't downshift and yet didn't have power to maintain speed on a moderate incline. All went away with a restart.

  9. #7
    Junior Member
    Member #
    7885
    Join Date
    Sep 2015
    Posts
    6
    I've dealt with this problem pretty much since day 1 on my 2014. Dealership always says everything is proper and they can't duplicate the problem. It seems to be to be most noticeable when you're trying to be light on the gas pedal, when Turbo is not really producing any boost. I've thought it might be a faulty throttle position sensor, but no luck convincing the mechanics that there is anything wrong. Mine also seems to be more noticeable since the variable valve timing system issue. (I just posted a big thread on my bad history with my vehicle if you're interested)

  10. #8
    Senior Member
    Member #
    3512
    Join Date
    Dec 2013
    Location
    Richmond, Texas
    Posts
    518
    Have you tried taking the issue to JLR North America?
    You shouldn't have to stop just because the pavement does! 2012 Range Rover Evoque Pure Plus Coupe, 2009 Land Rover LR2 HSE traded, 2008 Land Rover LR2 SE traded.

  11. #9
    Junior Member
    Member #
    7562
    Join Date
    Mar 2015
    Posts
    24
    To the OP, I hate to say it but I think you are experiencing "Life with Evoque". If your engine was misfiring it would immediately throw a code for sure, misfires trip emission codes. etc. My 2015 has run jerky since day one. Hesitates badly when trying to accelerate from dead stop. Press the gas nothing happens...wait for it, wait for it...then all of the sudden it lurches forward, somewhat dangerous when pulling out and makes you look like a boy racer. I just had it in the dealer for other problems that had multiple fault lights tripping (4x4 fault, ABS not working, etc.) and of course they couldn't replicate it but they did reflash my transmission ECU and now there is hesitation at higher speeds. I'm about 1 step from getting rid of this pos, it really is not very pleasurable to drive and very jerky... the built in delay is very frustrating. I did purchase a Sprint Booster and am going to install it soon, have been down ill but look for my Sprint Booster post under the Modifications forum as I'll post the results once I've finally installed it. Good luck with your issue and if you find a cure please post!

  12. #10
    Senior Member
    Member #
    7080
    Join Date
    Sep 2014
    Posts
    335
    Life with Evoque isn't all that bad. You are correct that the transmissions are the weak link. The real weak link is trying to make a 3900 lb luxury SUV behave like an econo box. Let the motor run, its a sweet piece. Drop your foot and let the rpms build and the transmission is fabulous. Leave it in drive and its just plain sucks. At least drive it in sport mode and I bet a lot of your problems go away. BTW, in stop/go traffic always go to paddles to keep motor out of turbo spool zone. There is no built in delay. That's just silly. Its called turbo lag and if your transmission is performing properly it is actually very minor as the motor is on boost ~1800rpms!
    I would call the acceleration Surgy esp if you leave it in drive.
    Last edited by ddsski; 10-15-2015 at 01:05 PM.

Page 1 of 2 1 2 LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. White smoke under acceleration
    By bluefang08 in forum Evoque Forum
    Replies: 8
    Last Post: 05-31-2015, 12:32 PM
  2. Grinding Noise During Acceleration
    By mconde in forum Evoque Maintenance
    Replies: 2
    Last Post: 01-28-2015, 09:15 PM
  3. Difference in acceleration after installing new wheels
    By Vachau01 in forum Evoque Wheels & Tires
    Replies: 8
    Last Post: 08-14-2014, 07:26 AM
  4. Replies: 15
    Last Post: 05-17-2014, 10:24 AM
  5. acceleration
    By Jim in forum Evoque Performance
    Replies: 23
    Last Post: 12-19-2013, 06:19 AM

Search tags for this page

2012 range rover drives jerky

,
why is my lr2 hesitating
Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.