Guys, as promised, EVOQUE TRIP UPDATE!

Guys, as promised, EVOQUE TRIP UPDATE!

This is a discussion on Guys, as promised, EVOQUE TRIP UPDATE! within the Evoque Forum forums, part of the Evoque Discussions category; I will right a more comprehensive post later today, as I have just arrived from FLORIDA. In the way from NY to FL, I had ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Senior Member
    Member #
    200
    Join Date
    Nov 2011
    Location
    Bayside, NY
    Posts
    124

    Angry Guys, as promised, EVOQUE TRIP UPDATE!

    I will right a more comprehensive post later today, as I have just arrived from FLORIDA.
    In the way from NY to FL, I had a flat tire, than e cracked windshield due to a stone in the road.

    On the way back, I was supposed to arrvie on Friday, Just got home, 18 hours later due to a mechanical problem.
    The carr stalled on us 8 times, until I could no longer go and called for assitance.

    Everytime I accelerate above 3 thousand RPM the car would stall, shake and a engine light plus a warning light would come on telling... RESTRICTIVE PERFORMANCE!

    Nice....the firsta time was at 4:19 in the morning, i the middle of I75 in Florida, no visibility, 100% COVERED FOG, man that was dangerous!!!, I removed my family in a very dark environment on the shoulder, so we did not stayed near the car, as many trucks went by.

    The LAND ROVER answered their phone after 8am, so it was quite a wait, as I wanted to know if they were aware of this code... the answrr was, HOW CAN WE KNOW... when you get to NY, bring it in and we will put in the compouter! no more words on this as I am a very unhappy camper with the Range Rover, I just got unluck with this vehicle from day one.

    Anyway, I am going to L.R. now and will advise later. PLUS GAS MILEAGE! I definitelly say that my SRT8 HEMI 6.4L does pretty much the same gas mileage, maybe theEVOQUE wins by 4 miles on the highway, but you can not accelerate over 3000RPM! it looks like the TURBO got a problem when it kicks in, or a oxigen sensor is screwed up, what would I know!
    Regards,
    brazeagle

  2. # ADS
    Ads


  3. #2
    Senior Member
    Member #
    374
    Join Date
    Feb 2012
    Posts
    251
    I certainly don't have an aswer for you but have had the same problem with another turbo car. It simply didn't like all the ethenol in some gas and would got into a "Limp Mode". Obviously I have no idea what gas you're putting in your Evoque.....just an idea I had. Good luck.

  4. #3
    Senior Member
    Member #
    200
    Join Date
    Nov 2011
    Location
    Bayside, NY
    Posts
    124
    I am not sure it is gas related as I drove 1400 miles and filled the tank 4 times, always used 93 octane from day one, and for this trip I only used 1xBP, 2xSUNOCO and 1xShell and it happend all the way from FL to NY everytime I accelarated to overtake, when the RPM reached 3.5K and over, the car stalled and I had to stop on the shoulder, shut down the engine, disconnect the battery and back on the road for another few hundred miles easy at 2K RPM only.
    I do think it is the TURBO, since a friend who is a mechanic explained that a defective turbo will do that.

    The car is at the dealer, I have a loaner, they gave me a EVOQUE Dynamic 2 door Silver, I was surprised that the 2 doors have a slightly bigger trunk.

    Anyway, I will post when the car is troubleshoot.
    Another thing was the BELTRONICS radar detector (LAST GENERATION) I bought for this trip, it will not work with the heated windshield, it will detect ONLY when you are in front of the radar gun (30 feet or so), I tested with another REGULAR car in FL and works really well, if it is not laser, it will detect Ka Band 2 to 4 miles earlier.
    Regards
    brazeagle
    Last edited by brazeagle; 02-26-2012 at 04:44 PM. Reason: TYPO

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Member
    Member #
    404
    Join Date
    Feb 2012
    Posts
    76
    I feel bad for you OP,
    Sounds like you got the worst of the crop or something. Mine is problem free thus far.

  7. #5
    Senior Member
    Member #
    200
    Join Date
    Nov 2011
    Location
    Bayside, NY
    Posts
    124
    Since new, lots of little issues, but now it became serious as I had a safety concern while standing on the shoulder at 4:19 am on a FULLY FOGGY WEATHER no visibility then a couple of times during daylight and again at NIGHT on the Pennsylvania Turnpike with problems again.
    Wife and a 7 years old where not very happy!
    Anyway, I will definitely advise you all when the issue is fixed or at least found, as I have a case open with L.R. England for other issues.
    Regards and stay safe.

  8. #6
    Senior Member
    Member #
    200
    Join Date
    Nov 2011
    Location
    Bayside, NY
    Posts
    124
    So far Land Rover has detected pistons 2 and 4 misfiring, they cannot figure it out why, they are in contact with Land Rover Technical Support (England) for a solution.

    Will post.
    Rergards,
    brazeagle

  9. #7
    Senior Member
    Member #
    1
    Join Date
    Mar 2011
    Location
    Austin, TX
    Posts
    320
    Wow, sorry to hear about all your troubles. Thanks for keeping us posted though, hopefully Land Rover will make the situation right for you.

  10. #8
    Senior Member
    Member #
    434
    Join Date
    Feb 2012
    Location
    Ten Mile, TN
    Posts
    326
    Quote Originally Posted by brazeagle View Post
    So far Land Rover has detected pistons 2 and 4 misfiring, they cannot figure it out why, they are in contact with Land Rover Technical Support (England) for a solution.

    Will post.
    Rergards,
    brazeagle
    That sure explains the poor fuel mpg and the lack of performance.

    Sorry to hear about your troubles. I hope they get it sorted out Very Fast!



    2012 Dynamic 5 door, Fuji White and Santorini black top, Lunar interior Style 6 sparkle rims, Climate comfort, adaptive dynamic, Sat and HD radio
    2012 Custom Vehicle Operations, FLTRXSE Harley Davidson Roadglide White Gold Pearl and Starfire Black
    2013 Custom Vehicle Operations, FLHRSE5 Harley Davidson Road King an ultra-premium Diamond Dust, Obsidian and Palladium paint scheme, 110th Anniversary Edition.

  11. #9
    Member
    Member #
    404
    Join Date
    Feb 2012
    Posts
    76
    Yeah keep us posted.
    Good to know and yeah same as ^ that would explain why your mpg is so bad.

  12. #10
    Senior Member
    Member #
    200
    Join Date
    Nov 2011
    Location
    Bayside, NY
    Posts
    124
    More news
    Got my EVOQUE back today, they could not replicate the problem, so they cleared the codes for PISTON 2-4 misfire and back to road. They say it may be BAD GAS related.

    I know you all gonna say! SAGA!!! or NOT POSSIBLE!!!

    BUT IT CONTINUES, as I drove off from the dealer, when about 6 miles away entering the highway (LIE), I noticed that my sterring wheel heating lighted up but never really warmed up, them I tried the controls in the steering wheel and NOTHING WORKED. Called them back and U-TURN back to the dealer...they tested, everything receives power, but no repsonse, they could not figure it out and told me that may be a short on the steering wheel itself! they ordered a new complete steerign wheel. It will arrive in 2 weeks, when I will go back to them and have it replaced!!!

    WHAT DO YOU THINK ABOUT THAT! is it a bad batch of EVOQUE or just unluck again!
    Regards,
    brazeagle

Page 1 of 2 1 2 LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

2013 evoque problems
,
2013 evoque updates
,

2013 range rover evoque changes

,
evoque 2013 changes
,
evoque limp mode
,

evoque problems

,
evoque range rover 2013 changes
,
range rover evoque 2013 changes
Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.