Transmission problems with a 2013?

Transmission problems with a 2013?

This is a discussion on Transmission problems with a 2013? within the Evoque Forum forums, part of the Evoque Discussions category; Hi everyone, first time posting here. I seem to have never ending problems with my Evoque Prestige. It all started a couple months after I ...

Results 1 to 6 of 6
  1. #1
    Junior Member
    Member #
    7789
    Join Date
    Aug 2015
    Posts
    3

    Transmission problems with a 2013?

    Hi everyone, first time posting here. I seem to have never ending problems with my Evoque Prestige. It all started a couple months after I bought it, the A/C didn't work. After driving through the hot summer, they could finally fix it 2 months later.

    I have had low coolant lights come on, took it in for that.

    My interior dome light comes on when I start the car, and it doesn't turn off. You have to manually turn it off. I have taken the car in twice, problem still isn't fixed. Other times, no lights come on when you start the car.

    Took the car in because it "clunks" when slowing down sometimes. Dealership said they saw the issue on the computer, but couldn't duplicate it, so they did a software update.

    Now, I was driving last night, and the car got super jerky while accelerating. It was like the car was trying to jump forward. Eventually, it smoothed out and accelerated. Tried accelerating from the next light, and its like the transmission wouldn't catch as I was accelerating, the car just got louder and louder and wouldn't move. Eventually it caught, the engine light came on, and I limped it home.

    Has anyone else had this problem? The car only has 36,000km on it, I think I bought a lemon!

  2. # ADS
    Ads


  3. #2
    Junior Member
    Member #
    7789
    Join Date
    Aug 2015
    Posts
    3
    Just an update, it wasn't the transmission, it was the fuel pump. That explains the jerking forward, but how can the engine keep revving high if it's not getting any fuel?

  4. #3
    Senior Member
    Member #
    3512
    Join Date
    Dec 2013
    Location
    Richmond, Texas
    Posts
    518
    Quote Originally Posted by Evo_D View Post
    Just an update, it wasn't the transmission, it was the fuel pump. That explains the jerking forward, but how can the engine keep revving high if it's not getting any fuel?
    I agree with you. It sounds like the transmission wasn't in gear. If service still has the vehicle make sure they check the tranny fluid. Also, everything is controlled by the computer so did they mention any codes that triggered the check engine light? A fuel pump isn't going to cause the engine to rev without moving.
    You shouldn't have to stop just because the pavement does! 2012 Range Rover Evoque Pure Plus Coupe, 2009 Land Rover LR2 HSE traded, 2008 Land Rover LR2 SE traded.

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Junior Member
    Member #
    9105
    Join Date
    Nov 2016
    Posts
    2
    Did you end up getting the interior light problem sorted? Mine is doing the same thing

  7. #5
    Junior Member
    Member #
    7789
    Join Date
    Aug 2015
    Posts
    3
    Hi IpanemaSand, they eventually did fix it. I had to bring it in 2 or 3 times though. After they "fixed" it, it would start happening again a month later. I don't know what they ended up doing, but it seems to be fixed for good.

  8. #6
    Junior Member
    Member #
    6706
    Join Date
    Apr 2014
    Location
    Vancouver, Canada
    Posts
    27
    I have had the exact same issues with the transmission, fuel pump, coolant lights, plus a number of others. Just the other week, my engine light came on, just before I went to take it in to get it looked at, it jerked and I lost all power and movement (luckily I was only going 5 kms at the time). Timing chain snapped and ruined the entire engine. Engine replacement being done, under warranty.

    Be careful, have them check everything, including the timing chain, just in case.

    Let me know how it goes for you.

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 14
    Last Post: 07-22-2015, 04:57 AM
  2. Evoque Cylinder 1 problems
    By Mohand in forum Evoque Maintenance
    Replies: 2
    Last Post: 04-01-2014, 09:41 AM
  3. More Problems!
    By redrover in forum Evoque Forum
    Replies: 14
    Last Post: 03-20-2014, 07:01 PM
  4. Electronic Problems
    By redrover in forum Evoque Forum
    Replies: 5
    Last Post: 12-29-2013, 05:49 PM

Search tags for this page

2013 range rover evoque transmission problems

,
evoque 2013 gearbox problems
,
evoque transmission fault
,
evoque transmission issues
,
gearbox fault on range rover evouqe
,
land rover evoque transmission problems
,
range rover evoque 2014 transmission problems
,

range rover evoque transmission problems

Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.