Power/ cigarette outlet not working

Power/ cigarette outlet not working

This is a discussion on Power/ cigarette outlet not working within the Evoque Forum forums, part of the Evoque Discussions category; Could anyone tell me how i could get this power outlet in the center console to work on a 2012 Range Rover Evoque Prestige? I've ...

Results 1 to 5 of 5
  1. #1
    Junior Member
    Member #
    7139
    Join Date
    Oct 2014
    Posts
    9

    Power/ cigarette outlet not working

    Could anyone tell me how i could get this power outlet in the center console to work on a 2012 Range Rover Evoque Prestige? I've checked the fuses that I've been able to find & none are blown. Is there something that I'm missing? Name:  20160828_161136.jpg
Views: 785
Size:  2.38 MB

  2. # ADS
    Ads


  3. #2
    Super Moderator
    Member #
    1235
    Join Date
    Dec 2012
    Location
    Canal Fulton, Ohio
    Posts
    530
    Assuming the fuse is good, I believe it would be fuse number 52 in the passenger compartment fuse panel, and you don't have power with the engine running, or at least the ignition on... I would try another USB adapter to make sure your adapter hasn't gone Tango Uniform.

    Just a thought.

  4. #3
    Super Moderator
    Member #
    1235
    Join Date
    Dec 2012
    Location
    Canal Fulton, Ohio
    Posts
    530
    My MY13 has a second power outlet where the USB, Aux jack etc. is located. Do you have power at that outlet? Just curious.

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Junior Member
    Member #
    7139
    Join Date
    Oct 2014
    Posts
    9
    I didn't know there were fuses on the passenger side, i just checked the ones in the back & under the hood.. thank you! And yes i do have another outlet in the arm rest and the usb does work because that's where i normally keep it. I'm trying to get this one to work to use as a power supply for a dash camera I'm adding.

  7. #5
    Super Moderator
    Member #
    1235
    Join Date
    Dec 2012
    Location
    Canal Fulton, Ohio
    Posts
    530
    Jes2tngo, Did you find your power problem? Was fuse number 52 blown, and if so, did replacing it solve your issue?
    A UK Evoque forum member, posted he had the same problem as you do. Same year Evoque, and he posted his issue about the same time as you did. He says he has lost the ground connection to his power outlet. I posted on the UK site about your issue, and he wondered if you had fixed your power outlet, and what you found.

    Strange that a domestic, and a US model, would have the same issue come up within days of one another.

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 12V power outlets
    By aus1ander in forum Evoque Forum
    Replies: 3
    Last Post: 09-06-2019, 12:53 AM
  2. Power mirrors
    By Porschebreath in forum Evoque Forum
    Replies: 2
    Last Post: 03-03-2014, 06:00 AM
  3. loss of power
    By ssff43 in forum Evoque Maintenance
    Replies: 2
    Last Post: 11-13-2012, 02:11 PM
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.