New Evoque Died after 10 Days

New Evoque Died after 10 Days

This is a discussion on New Evoque Died after 10 Days within the Evoque Forum forums, part of the Evoque Discussions category; Hi All, Some sad news that my new 2 door dynamic Evoque (US) passed away after just 10 days. The car ran like a champ ...

Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1
    Junior Member
    Member #
    706
    Join Date
    Jun 2012
    Posts
    2

    New Evoque Died after 10 Days

    Hi All,
    Some sad news that my new 2 door dynamic Evoque (US) passed away after just 10 days. The car ran like a champ and I actually put on 1500 miles within 10 days.

    During one of these long traveling days, the car suddenly dropped from 70 to 40 mph in the fast lane and went into "restricted performance mode". This was flashing on the instrument panel, along with the check engine light.

    I thought it might be bad gas or just a system hiccup. I went on the side of the road and shutdown the car, then refueled it at the next stop. On the way home later that night, however it happened again!

    I had the car towed that night and service has no clue what the issue is! The computer codes were sent to corporate engineering with no answer after 14 days!!

    The car is still in the shop and the dealer is trying to figure out if we can get money back, swap out for a new Evoque or get an older Sport.

    Hate to share bad news. I love the car but to me, this is a major safety concern.

    jls

  2. # ADS
    Ads


  3. #2
    Senior Member
    Member #
    1
    Join Date
    Mar 2011
    Location
    Austin, TX
    Posts
    320
    Wow, that sucks. I hope it's just a one off fluke. Please keep us updated how the dealer fixes the situation.

  4. #3
    Senior Member
    Member #
    374
    Join Date
    Feb 2012
    Posts
    251
    How much ethanol is in your gas? Too much will cause your problem!

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Junior Member
    Member #
    715
    Join Date
    Jun 2012
    Posts
    2
    I had the same error come up today, I have 6500 miles on mine. Calling LR in the morning.....frustrated.

  7. #5
    Junior Member
    Member #
    690
    Join Date
    May 2012
    Location
    California
    Posts
    16
    Not cool! Now I'm worried about mine that I'm picking up on Friday!

  8. #6
    Junior Member
    Member #
    646
    Join Date
    May 2012
    Posts
    22
    This is the thing I don't get with Land Rover.Why do they take so long to do everything?

    Here they have a chance to improve their brand and clear a historically bad reputation, yet they continue to stuff it up.

    Sorry for the rant, however, even when I enquired online about a test drive, they phoned me 5 weeks later. By that time I had already placed my order. Never received the brochure they promised. Even simple enquiries get screwed up.

    Wow, that feels better.
    Sorry for your problems jls, keep us posted.
    Maybe try calling LR head office personally to see if you can get things escalated. Remind them that their brand is on the line.
    Last edited by zimbakin; 06-11-2012 at 12:26 AM.

  9. #7
    RRR
    RRR is offline
    Junior Member
    Member #
    718
    Join Date
    Jun 2012
    Posts
    3
    Hi My Evoque has died too -- Just like described above. I have it on Video -- 3 versions back to back showing the Car Shutdown on the highway. IPhone was handy -- Very scary and dangerous to drive. It kills the throttle and you have no control. They tell me every time it rains theTurbo can get water in it. It was raining -- not when it died *** Not sure this is a good thing. 2 Door Black with all the options -- They gave me back the car and said I am on my own. So it begins -- expect club membership to all owners soon - I do not think this is just me -- 3200 miles
    Last edited by RRR; 06-12-2012 at 04:25 AM.

  10. #8
    Junior Member
    Member #
    715
    Join Date
    Jun 2012
    Posts
    2

    performance limited warning

    Well I called LR and they told me that if my Evoque didn't still have the error there wasn't too much they could do. They advised me to drive it and if it happend again to call them and they would tow it in. It was raining and has been here for about a week so I am wondering if that had something to do with it, I sure hate that I purchased a 60k car that I might not be able to drive in the rain....

  11. #9
    Senior Member
    Member #
    328
    Join Date
    Jan 2012
    Location
    Minneapolis, MN
    Posts
    482
    So what did you all do to "reset" the car? Just turn off and turn on again?



    100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

  12. #10
    RRR
    RRR is offline
    Junior Member
    Member #
    718
    Join Date
    Jun 2012
    Posts
    3
    When the car shuts down -- and gets in this Mode -- you have to pull over -- re - start -- and take it back to dealer to get engine light turned off -- I am not sure we as owners realize the inconvience we can expect. Heads up - never fill the vehicle with gas while leaving the engine running *** it will set off the engine light. There is another issue you can expect ** the transmission will stick in second gear - about 15 - 25 seconds -- not shift -- no throtte -- either will kick in -- oryou have to pull over and restart. It has happened twice and once after a fix from RR -- still yet to get it on my IPhone -- I had a good friend with me during one episode ** we both just stared at the gear box and went what was that. We both said bring it back to the dealer -- I did -- they replaced the entire electronics for the shift --- which was good of them. It returned just before this Turbo problem. I want a new car -- If I keep going back with engine lights -- the better chances. This forum is where we as owners need to begin to get our vehicles. replaced with improved fixed ones.





    Quote Originally Posted by Evocurious View Post
    So what did you all do to "reset" the car? Just turn off and turn on again?

Page 1 of 5 1 2 3 ... LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 4400 Miles, Seven Days In My Evoque
    By Skywagon in forum Evoque Forum
    Replies: 5
    Last Post: 07-18-2012, 08:34 AM
  2. 84 days and counting in Arizona :)
    By NancyPants in forum Introductions
    Replies: 2
    Last Post: 02-16-2012, 07:40 PM
  3. 1344 miles in two days
    By CanadianEvoque in forum Evoque Forum
    Replies: 18
    Last Post: 02-08-2012, 09:44 AM

Search tags for this page

2013 range rover evoque check engine light
,
evoque engine shut down
,
evoque forum
,

evoque restricted performance

,

range rover evoque restricted performance

,
range rover restricted performance warning
,
restricted performance evoque
,

restricted performance range rover evoque

Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.