2013 Evoque Dynamic FAIL

2013 Evoque Dynamic FAIL

This is a discussion on 2013 Evoque Dynamic FAIL within the Evoque Forum forums, part of the Evoque Discussions category; 3 months after ordering our $62K Evoque Dynamic it finally arrived and we picked it up today. The dealership is less than a mile from ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Junior Member
    Member #
    1131
    Join Date
    Nov 2012
    Posts
    6

    Thumbs up 2013 Evoque Dynamic FAIL

    3 months after ordering our $62K Evoque Dynamic it finally arrived and we picked it up today. The dealership is less than a mile from the highway and as I started down the on-ramp the car would not accelerate beyond 25mph. I had to drive 2 miles in the emergency lane with trucks speeding buy us, limping the car back to the dealership. Obviously no one had test driven the car before we drove it off the lot ...although the car had 17 miles on it. Hmm Perhaps 17 miles creeping along at less than 25mph? I dropped the keys off and told the dealer to tear up my check and paperwork ..... Beyond disappointing !!! I really don't care what they say the problem is, if a manufacturer and dealer will let you take possession of a vehicle that is faulty and dangerous I can't bring myself to hoping things will be better in the future. Unfortunately I'm off to the BMW dealer on Monday!

  2. # ADS
    Ads


  3. #2
    Member
    Member #
    732
    Join Date
    Jun 2012
    Location
    Hurst, Texas
    Posts
    72
    Was there an engine or restricted performance indication on the dash? Did this happen on your test drive before accepting the car? Sorry to hear about that and I'm very curious what could cause that and if it is a simple dealer preparation item they missed on the checklist.

  4. #3
    Junior Member
    Member #
    1131
    Join Date
    Nov 2012
    Posts
    6
    Quote Originally Posted by cousin.it View Post
    Was there an engine or restricted performance indication on the dash? Did this happen on your test drive before accepting the car? Sorry to hear about that and I'm very curious what could cause that and if it is a simple dealer preparation item they missed on the checklist.
    There was NO engine light or restricted performance light on the dash. We did not drive the car before accepting it, the dealer assured me that everything was checked out with the prep. After looking through the forum here It seems this is a problem that is know to LR when driving in wet conditions, and it was snowing today here in Utah today.

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Member
    Member #
    919
    Join Date
    Aug 2012
    Location
    USA
    Posts
    44
    Some idiot didn't take the car out of Transport Mode before delivering it to you. There is a speed limiter that prevents the car going over 25mph when it is in Transport Mode. The car probably was never put through Pre Delivery Inspection. Seen it before, unfortunately. Sales people are in too big a hurry to get you in the car to do it right sometimes.

  7. #5
    Junior Member
    Member #
    1131
    Join Date
    Nov 2012
    Posts
    6
    Quote Originally Posted by Wrenchbender412i View Post
    Some idiot didn't take the car out of Transport Mode before delivering it to you. There is a speed limiter that prevents the car going over 25mph when it is in Transport Mode. The car probably was never put through Pre Delivery Inspection. Seen it before, unfortunately. Sales people are in too big a hurry to get you in the car to do it right sometimes.
    I was actually thinking it could be something like that, then I stayed up late reading all of the posts about the malfunctioning perhaps caused by condensation in the inter cooler. If the dealer says it was just the transport mode setting would you still buy the car given all of the issues on here about the car dropping into safe mode due to inter-cooler condensation or something else ... When they still don't have a fix yet?

  8. #6
    Junior Member
    Member #
    1073
    Join Date
    Oct 2012
    Posts
    13
    PCDan : Sorry to hear that, I would say that I am a bit concerned , I too just got my 2013 Dynamic Evoque from Utah a week ago today! So far knock on wood, everything is fine. I have been in snow, rain & negative temperatures & have had no problems. The car isn't even kept garaged. Already put about 1000 miles on it. I will keep you all posted.

  9. #7
    Member
    Member #
    255
    Join Date
    Dec 2011
    Location
    Gilroy, CA
    Posts
    87
    Quote Originally Posted by PCDan View Post
    If the dealer says it was just the transport mode setting would you still buy the car given all of the issues on here about the car dropping into safe mode due to inter-cooler condensation or something else ... When they still don't have a fix yet?
    Sure, but I would ask for a better price first for your trouble. If it makes you feel any better, many of us including me have had no problems with this car. On the other hand my brand new Porsche (German reliability) has already been flat bedded back to the dealer.

  10. #8
    Junior Member
    Member #
    1131
    Join Date
    Nov 2012
    Posts
    6
    The car was still in "transport mode" as Wrenchbender figured. Having the car delivered.

  11. #9
    Member
    Member #
    255
    Join Date
    Dec 2011
    Location
    Gilroy, CA
    Posts
    87
    Let us know how you like it.

  12. #10
    Senior Member
    Member #
    734
    Join Date
    Jun 2012
    Posts
    137
    Can transport mode be enabled and disabled by the user? It would be nifty as a valet mode
    How to reset Warnings on your Evoque (Video)
    12 Evoque Dynamic 5D Fuji White/Onyx
    05 G35
    08 ISF
    09 GTR

Page 1 of 2 1 2 LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 2013 Evoque prices paid
    By Silverman in forum Evoque Purchasing
    Replies: 46
    Last Post: 07-09-2014, 05:50 PM
  2. What would you like to see on the 2013 Evoque?
    By dascrow in forum Evoque Forum
    Replies: 58
    Last Post: 05-01-2014, 02:48 PM
  3. 2013 dynamic
    By EVOQUEMT in forum Evoque Forum
    Replies: 2
    Last Post: 11-05-2012, 08:34 AM
  4. Evoque sold out until 2013
    By dascrow in forum Evoque News
    Replies: 4
    Last Post: 08-21-2012, 09:27 PM
  5. Why no 2013 Dynamic with Oxford leather in USA?
    By CASEY in forum Evoque Purchasing
    Replies: 2
    Last Post: 07-27-2012, 12:33 PM

Search tags for this page

2013 evoque

,
2013 evoque no dynamic mode
,

2013 evoque problems

,

2013 evoque reliability

,
common issues with 2013 evoque
,
evoque 2013 problems
,

evoque problems 2013

,
problems with the 2013 evoque
Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.