Sirius....stuck on Acquiring Signal

Sirius....stuck on Acquiring Signal

This is a discussion on Sirius....stuck on Acquiring Signal within the Evoque Maintenance forums, part of the Land Rover Evoque Garage category; I recently purchased a 2013 Evoque Pure Plus and I love it. The only problem that I'm having is that the Sirius radio is stuck ...

Results 1 to 4 of 4
  1. #1
    Junior Member
    Member #
    7497
    Join Date
    Feb 2015
    Posts
    2

    Sirius....stuck on Acquiring Signal

    I recently purchased a 2013 Evoque Pure Plus and I love it.
    The only problem that I'm having is that the Sirius radio is stuck on "acquiring signal".
    AM and FM work fine, but the Sirius doesn't play anything...not even the preview on channel 184.
    It's stuck on channel 184 and the display says acquiring signal.

    I transferred my subscription and Sirius says that it's a problem with the vehicle, maybe the antenna. I've talked with them several times....always the same response. It's not them, it's the car.
    I've been searching online for similar issues, but I haven't found any that are specific to the Evoque.
    I am aware of the bluetooth connectivity conflict and have made sure to not have bluetooth connected when attempting to activate Sirius.

    What I'm thinking is that I need to reset the radio--completely clear everything, turn it on, and then resend the Sirius activation signal and see if it will pick it up.

    I've seen posts for other vehicles (ie Jaguar) to reset the system by disconnecting the battery cables, touching them together, waiting a bit, and then reconnecting.

    I'm concerned about disconnecting the battery....will it have any ill effects on the car?
    Does anyone know of another way to reset the radio?
    Does anyone have any other thoughts or suggestions?

    Any help or guidance is much appreciated.

  2. # ADS
    Ads


  3. #2
    Super Moderator
    Member #
    1235
    Join Date
    Dec 2012
    Location
    Canal Fulton, Ohio
    Posts
    525
    I don't think disconnecting the battery cables and touching them together is a good idea. I understand your thoughts about a complete reset of the radio, but I don't think there is any power going
    to the radio once the ignition is switched off. There are anti-theft radios, like in my BMW, that always have power. Once power is removed, for any reason(dead battery, theft etc.), you have to
    input a special code to get the radio to work again. I don't think this applies to our Exoque radios.

    If you really want to try a no power reset, I would pull the radio fuses, that would be the same as disconnecting the battery, but easier and safer.

    I found this in my owner's manual, you can double check this by looking in yours.

    LUGGAGE COMPARTMENT FUSE BOX
    Fuse Amps Fuse color Circuit Protected
    2 RA 15 blue Radio module
    3 RA 10 redDigital radio/TV module
    Last edited by Rsquared; 02-12-2015 at 11:03 AM.

  4. #3
    Junior Member
    Member #
    7497
    Join Date
    Feb 2015
    Posts
    2
    Thanks. I did that yesterday. Removed fuses. Left them out for about 15 min. Started the car without them. Shut the car off. Reinstalled fuses. Started the car. Powered up the radio.
    But the system didn't clear. All FM presets were still there, as were Navigation settings, etc.
    So removing the fuses didn't reset the system like I thought (and hoped) it would.
    Is there something else I should have done?

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Super Moderator
    Member #
    1235
    Join Date
    Dec 2012
    Location
    Canal Fulton, Ohio
    Posts
    525
    Looks like you did a very comprehensive test. The only other thing I would have tried, was to power up the radio after I pulled the fuses, to prove that all power was removed from the
    unit, and a fuse wasn't missed.

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Anyone Have "Gearbox Fault" Message, while stuck in P?
    By markdartj in forum Evoque Forum
    Replies: 3
    Last Post: 03-31-2019, 07:32 AM
  2. My rear seat belt doesn't real back, its stuck.
    By Babud in forum Evoque Forum
    Replies: 5
    Last Post: 05-02-2014, 02:32 PM
  3. Sirius
    By street5927 in forum Evoque Forum
    Replies: 0
    Last Post: 11-15-2013, 05:22 AM
  4. Led turn signal bulbs
    By LIONHEAD in forum Evoque Accessories
    Replies: 1
    Last Post: 06-13-2013, 10:17 PM
  5. Sirius/xm radio
    By Brian18330 in forum Evoque Forum
    Replies: 7
    Last Post: 05-16-2013, 05:04 PM

Search tags for this page

acquiring signal range rover

,

can hear sirius radio but it is stuck on acquiring

,

range rover sirius module

,

range rover sirius radio stuck on acquiring signal

,

sirius radio acquiring signal problem 2015

,

sirius radio stuck aquiring signal

,

xm radio stuck on acquring signal

Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.