Air cooler temperature Sensor failed

Air cooler temperature Sensor failed

This is a discussion on Air cooler temperature Sensor failed within the Evoque Maintenance forums, part of the Land Rover Evoque Garage category; Suddenly, 4 days ago, my MPG dropped from 23 MPG to 18 MPG, during my routine 90 mile roundtrip commute to work. Then the engine ...

Results 1 to 6 of 6
  1. #1
    Junior Member
    Member #
    281
    Join Date
    Dec 2011
    Location
    Chicago, IL
    Posts
    20

    Air cooler temperature Sensor failed

    Suddenly, 4 days ago, my MPG dropped from 23 MPG to 18 MPG, during my routine 90 mile roundtrip commute to work. Then the engine warning light came on. I took the car to the dealer and they said the Air Cooler Temperature Sensor failed and needed to be replaced. It will be flown in from Memphis TN. What this has to do with MPG, and whether this solves the problem, remains to be seen. I have 7200 miles on the car already and will have them change the oil anyways, despite what the manual says (Dealer recommended it also). Will report on the fix, hopefully this week.

  2. # ADS
    Ads


  3. #2
    zerofeel
    Guest
    Almost sounds like they are talking about an O2 censor. Failing O2 sensor would also explain that bad gas mileage.

  4. #3
    Junior Member
    Member #
    281
    Join Date
    Dec 2011
    Location
    Chicago, IL
    Posts
    20
    The temperature sensor was in stock and was replaced, the sensor was bad. The car was test driven and returned to me. I drove it home (12 miles). The next morning the car did not start properly, and the "Restricted Driving" warning immediately came on, along with the engine trouble amber light. I drove immediately to the dealer, the car was coughing and lurching the whole way.
    The service manager indicated that the computer reported two codes, a misfire, and a lean code. Headquarters in New Jersey was being sent all the diagnostics, and the dealer was following their lead. They are ordering new injectors, something for the manifold, a high pressure hose, etc, from England. The car is sitting for now, and maybe I will see parts this week. I have been buying premium gas as required, maybe a bad fill-up? I have been buying from the same gas station consistently, and the car has 7300 miles on it. I will continue to report, it may be a week. I have an LR2 loaner for now.

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Junior Member
    Member #
    281
    Join Date
    Dec 2011
    Location
    Chicago, IL
    Posts
    20
    I picked up the car on March 30, the dealer had test driven it 200 miles with 4 new injectors and no amber warning lights. But Monday morning it started with a cold misfire, and amber light. Back to the dealer. It has now been in the shop 23+ days. Landrover New Jersey HQ has uploaded all my diagnostics from my dealer. Nothing being done here in Chicago, no one has a clue. Waiting for some wizard to divine the result. ??????? Time for someone to step up to the plate and take responsibility...Customer relations? Lemon Law goes into effect soon.

  7. #5
    Junior Member
    Member #
    281
    Join Date
    Dec 2011
    Location
    Chicago, IL
    Posts
    20
    Quote Originally Posted by Jaybird View Post
    I picked up the car on March 30, the dealer had test driven it 200 miles with 4 new injectors and no amber warning lights. But Monday morning it started with a cold misfire, and amber light. Back to the dealer. It has now been in the shop 23+ days. Landrover New Jersey HQ has uploaded all my diagnostics from my dealer. Nothing being done here in Chicago, no one has a clue. Waiting for some wizard to divine the result. ??????? Time for someone to step up to the plate and take responsibility...Customer relations? Lemon Law goes into effect soon.
    UPDATE April 12. LR regional tech specialist came in and couldn't diagnose the problem. Injector 1 had misfired again earlier. They switched the wires from Injector 1 to Injector 4 to try to make injector 4 misfire. No dice. Car still with dealer, now over 30 days. Dealer drives it daily to see if condition recurs. So far, no problems and I believe MPG is normal (approx 23mpg). But still no definite answer. I have taken my concern to the next level at Landrover HQ, NJ. So far no one in a position of responsibility has contacted me. And get this...the customer relations guy says that it takes 3-4 DAYS!! just to have a supervisor from NJ return my call!! Something terribly wrong with that....what would you do??

  8. #6
    Junior Member
    Member #
    281
    Join Date
    Dec 2011
    Location
    Chicago, IL
    Posts
    20
    Read my recent posts under Real World Gas Mileage for the update on my car.

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

censor cooler
,

cooler temperature sensor

,
evoque recommended oil
,
khd grate cooler temperature sensor
,
novar coolers temperature sensor
,
temperature sensors used in air cooler area
,
weekly temperature sensors cooler
,
whats a cooler temp sensor
Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.