2012 RR Evoque - new problem?

2012 RR Evoque - new problem?

This is a discussion on 2012 RR Evoque - new problem? within the Evoque Maintenance forums, part of the Land Rover Evoque Garage category; So, on the way to work this morning my car just died. I have had zero issues with this car up until this morning. I ...

Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    Junior Member
    Member #
    269
    Join Date
    Dec 2011
    Location
    Planet Houston
    Posts
    21

    2012 RR Evoque - new problem?

    So, on the way to work this morning my car just died.

    I have had zero issues with this car up until this morning.

    I was on the highway, thankfully REALLY early, and was just cruising along when it suddenly gave a violent lurch... and then crapped out. ALL dash lights came on, but I didn't get any 'message' from the car.

    Luckily I had enough forward momentum going, and there were no other cars next to me, that I was able to get it pulled over onto the shoulder. I shut everything off, turned the car all the way off, waited about 10 seconds and it started back up. I said a little prayer and continued on my course.

    I contacted service and they advised me to have it towed in by LR Roadside Assist, so I did that. I now have a loaner (LR 2 hahaha ) and will just have to wait until service calls me tomorrow.

    *heavysigh*

    I will report back once I know more details.

    Later!

    Lis

  2. # ADS
    Ads


  3. #2
    Member
    Member #
    716
    Join Date
    Jun 2012
    Location
    Stamford, CT
    Posts
    90
    I know this is an old post but did they ever determine the cause of your issue?

  4. #3
    Junior Member
    Member #
    269
    Join Date
    Dec 2011
    Location
    Planet Houston
    Posts
    21
    It's not that old

    The only news I have for today is that the codes that were stored showed COMMUNICATION FAILURES in FOUR MODULES.

    They are keeping the car and will contact LR on Monday.

  5. Remove Advertisements
    EvoqueForums.net
    Advertisements
     

  6. #4
    Member
    Member #
    716
    Join Date
    Jun 2012
    Location
    Stamford, CT
    Posts
    90
    OK keep us posted. How many miles do you have yours and what model? I just took delivery of my Coupe Pure Premium at the beginning of the month and I'm monitoring these forums for any issues. Your issue does seem to be a common one, although I can't tell how widespread. Anyway, I hope they sort things out for you and provide decent service.

    BTW, love the guitar-playing monkey, hah!

  7. #5
    Junior Member
    Member #
    269
    Join Date
    Dec 2011
    Location
    Planet Houston
    Posts
    21
    2012 Pure+ Coupe with 5800 miles on it.

    I stole the monkey from someone on the internet somewhere

  8. #6
    Member
    Member #
    716
    Join Date
    Jun 2012
    Location
    Stamford, CT
    Posts
    90

  9. #7
    Junior Member
    Member #
    269
    Join Date
    Dec 2011
    Location
    Planet Houston
    Posts
    21
    Quote Originally Posted by EvoGoon View Post
    Similar... but not exactly. I wasn't driving in the rain, or under load or anything.

    Just weird. And Scary!

  10. #8
    Junior Member
    Member #
    269
    Join Date
    Dec 2011
    Location
    Planet Houston
    Posts
    21
    Didn't have any contact with service yesterday, but on Monday afternoon they had been checking things like battery, cables, fuses, grounds, etc., and could not find any problems. Hopefully they will have some info today. *shrugs*

  11. #9
    Junior Member
    Member #
    269
    Join Date
    Dec 2011
    Location
    Planet Houston
    Posts
    21
    Nothing to report. They still have my Evoque and I am still in the Loaner Rover

  12. #10
    Member
    Member #
    716
    Join Date
    Jun 2012
    Location
    Stamford, CT
    Posts
    90
    Wow, you're going on 2 weeks tomorrow. That's a long time and not very confidence inspiring. I'd suggest the dealer call in an expert from corporate and check your lemon laws in your state.

Page 1 of 3 1 2 3 LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. My Engine Problem will become a Technical Service Bulletin
    By malharden in forum Evoque Maintenance
    Replies: 329
    Last Post: 09-12-2018, 10:42 AM
  2. 2012 Range Rover Evoque at 2012 Toronto Auto Show
    By dascrow in forum Evoque Media
    Replies: 2
    Last Post: 02-28-2012, 09:54 AM

Search tags for this page

2012 range rover evoque problems
,
evoque battery problems
,
evoque issues
,
evoque problem
,

evoque problems

,
problems with evoque
,
range rover evoque problems
,
rr evoque problems
Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.