Charging system Failure

Charging system Failure

This is a discussion on Charging system Failure within the Evoque Maintenance forums, part of the Land Rover Evoque Garage category; So I got this on the way to work today in my '13 Dynamic. Stopped part way, turned the engine off and started it again... ...

Results 1 to 3 of 3
  1. #1
    Member
    Member #
    7533
    Join Date
    Feb 2015
    Posts
    46

    Charging system Failure

    So I got this on the way to work today in my '13 Dynamic.
    Stopped part way, turned the engine off and started it again... Started fine.
    Got to work, and at lunch, I metered it (sitting 4 hrs in freezing temps).
    Measured 12.2V (connected to car obviously) and 14.9V running.
    Seems like battery is dying....? Should be 12.7V?
    If it's original, it's done good to last 5+ years...

    Sent from my SM-G965U using Tapatalk

  2. # ADS
    Ads


  3. #2
    Member
    Member #
    7533
    Join Date
    Feb 2015
    Posts
    46
    Sat overnight in freezing temps, fired right up. Looked at the battery and it's an 790cca Interstate with 6 year warranty. No idea if it's original....
    So, bad sensor...?

    Sent from my SM-G965U using Tapatalk

  4. #3
    Member
    Member #
    7533
    Join Date
    Feb 2015
    Posts
    46
    Wow.. Just nobody on this forum anymore?
    I disconnected the battery, cleaned the posts and clamps, checked the two electrical connectors on top of battery... Fault still there.

    Sent from my SM-G965U using Tapatalk

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Charging system fault
    By fredo in forum Evoque Forum
    Replies: 1
    Last Post: 06-25-2019, 12:13 PM
  2. Electronic Display Failure
    By pwhiz in forum Evoque Maintenance
    Replies: 6
    Last Post: 01-14-2019, 07:43 AM
  3. Cam Sproket Failure
    By Larry in forum Evoque Forum
    Replies: 0
    Last Post: 08-23-2018, 05:30 PM
  4. Land Rover Recalls 40,551 SUVs for Airbag Failure
    By Rovingvic in forum Evoque Forum
    Replies: 1
    Last Post: 08-13-2014, 10:58 AM
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.