Evoque Speedo meter mal function

Evoque Speedo meter mal function

This is a discussion on Evoque Speedo meter mal function within the Evoque Performance forums, part of the Land Rover Evoque Garage category; Hello all, My Evoque speedo started playing up when it was only 6 months old. Problem is that the dial doesn't work properly and sometime ...

Results 1 to 1 of 1
  1. #1
    Junior Member
    Member #
    2147
    Join Date
    Aug 2013
    Posts
    6

    Thumbs up Evoque Speedo meter mal function

    Hello all, My Evoque speedo started playing up when it was only 6 months old. Problem is that the dial doesn't work properly and sometime it is stuck at 0kmh when driving at 100kmh. I was lucky that I had my separate navigator and the digital display. RR says it is the first time they found it. My evoque is very poor performer and its rear heating was working for about 8 months and it has become dysfunctional. RR advised me today that this model doesn't have heating to the rear but they can't justify why it was working for last 8 months. The rear blower shuts above 20 C degrees. Unbelievable explanation by RR head office. Local agent was very surprised and was not happy to convey this message to me. Many more issues but minor. EF

  2. # ADS
    Ads


Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Radio Function Question
    By ABCRacer in forum Evoque Forum
    Replies: 5
    Last Post: 01-19-2013, 05:28 AM
  2. Disabling "Start/Stop" function ?
    By mihamusic in forum Evoque Forum
    Replies: 0
    Last Post: 08-20-2012, 03:00 PM
  3. Replies: 0
    Last Post: 08-14-2012, 09:35 AM

Search tags for this page

range rover evoque aftermarket speedo meter

Click on a term to search for related topics.
Find us on Google+
 

SEO by vBSEO ©2011, Crawlability, Inc.