Evoque Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2012 Range Rover Evoque that is giving me all kinds of fits. For the last few days I have had to resort to holding the key fob under the steering column to start the car. Tonight when I tried it, it wouldn't start. Dash would light up but it wouldn't turn over. Then after several attempts (and me continuously hitting the start button out of frustration) the dash has gone completely blank. However, my interior light and brake (I think parking) lights won't go off. Tried jumping it, nothing. Hard reset of the battery, nothing. If I push in or pull out the emergency brake button, the dash does display park. I have no clue as to what is going on. Any suggestions? Thanks in advance.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Also forgot to mention. I had disconnected the positive cable for about two minutes. When I reconnected, the speedometer needle was bouncing and the hazard button inside was blinking.
 

·
Registered
Joined
·
54 Posts
Try charging the battery, it could be a discharged battery fault.
 
  • Like
Reactions: Dlank74

·
Registered
Joined
·
7 Posts
Same issue, replace the battery.
When jumping the battery, hold the unlock bottom on the fob for 10 second.


Also forgot to mention. I had disconnected the positive cable for about two minutes. When I reconnected, the speedometer needle was bouncing and the hazard button inside was blinking.
 
1 - 7 of 7 Posts
Top