Evoque Forums banner
1 - 12 of 12 Posts

Registered
Joined
1 Posts
Discussion Starter · #1 ·
Hello everyone,

I just joined the forum today with an issue. The shift knob will not move out of the drive position. Luckily I was able to drive home, at which time I turned the car off. My hope was the problem would miraculously fix itself, so much for miracles.馃槪 When I shut the car off I received a fault message "car in drive", to be expected. When I restarted the car, the shift knob still would not move and the "D" was still lit on the indicator, but the car will not move. It's as if the car is in the park position, the engine runs, I can increase rpm's but no go. I am under the impression that there is an electrical switch/interlock on the brake that needs to be made before the shift knob can be moved. The car won't start w/o the brake being pressed, is there a separate switch for the shift knob? I did read on a different thread something about the secondary battery having something to do with the shift knob. My secondary battery has been out of commission for a while when my Eco Start/Stop stopped working.

Any insight or help would be much appreciated.

Thank You
 

Registered
Joined
105 Posts
Try a hard reset. Disconnect the battery, leave it for 10 minutes or so then reconnect.
 

Registered
Joined
3 Posts
Hello everyone,

I just joined the forum today with an issue. The shift knob will not move out of the drive position. Luckily I was able to drive home, at which time I turned the car off. My hope was the problem would miraculously fix itself, so much for miracles.馃槪 When I shut the car off I received a fault message "car in drive", to be expected. When I restarted the car, the shift knob still would not move and the "D" was still lit on the indicator, but the car will not move. It's as if the car is in the park position, the engine runs, I can increase rpm's but no go. I am under the impression that there is an electrical switch/interlock on the brake that needs to be made before the shift knob can be moved. The car won't start w/o the brake being pressed, is there a separate switch for the shift knob? I did read on a different thread something about the secondary battery having something to do with the shift knob. My secondary battery has been out of commission for a while when my Eco Start/Stop stopped working.

Any insight or help would be much appreciated.

Thank You
I have the exact same problem, did you manage to get this resolved?

Tiff
 

Registered
Joined
3 Posts
The issue I was experiencing was the gear selector being stuck in drive and refusing to moving out I.e stuck solid. Car started and although stuck in drive it didn't move, in the end I ended up buying a replacement gear shift module which resolved the issue
 

Registered
Joined
1 Posts
Hello everyone,

I just joined the forum today with an issue. The shift knob will not move out of the drive position. Luckily I was able to drive home, at which time I turned the car off. My hope was the problem would miraculously fix itself, so much for miracles.馃槪 When I shut the car off I received a fault message "car in drive", to be expected. When I restarted the car, the shift knob still would not move and the "D" was still lit on the indicator, but the car will not move. It's as if the car is in the park position, the engine runs, I can increase rpm's but no go. I am under the impression that there is an electrical switch/interlock on the brake that needs to be made before the shift knob can be moved. The car won't start w/o the brake being pressed, is there a separate switch for the shift knob? I did read on a different thread something about the secondary battery having something to do with the shift knob. My secondary battery has been out of commission for a while when my Eco Start/Stop stopped working.

Any insight or help would be much appreciated.

Thank You
Did you get if fixed, mines just done it today, was it an easy fix? Thanks
I have the exact same problem, did you manage to get this resolved?

Tiff
i have the same problem did you get it fixed? Thsnks
 

Registered
Joined
3 Posts
Did you get if fixed, mines just done it today, was it an easy fix? Thanks

i have the same problem did you get it fixed? Thsnks
Yes I did, I replied just above this, it was the gear shifter module, I purchased a new one from LR and fitted it myself, tbh it is relatively straight forward, think you also need a torx screwdriver (can't remember which size)... there is a video on youtube on how to remove the centre console which should help - let me know if you can't find it and ill dig it out for you
 

Registered
Joined
4 Posts
Hello everyone,

I just joined the forum today with an issue. The shift knob will not move out of the drive position. Luckily I was able to drive home, at which time I turned the car off. My hope was the problem would miraculously fix itself, so much for miracles.馃槪 When I shut the car off I received a fault message "car in drive", to be expected. When I restarted the car, the shift knob still would not move and the "D" was still lit on the indicator, but the car will not move. It's as if the car is in the park position, the engine runs, I can increase rpm's but no go. I am under the impression that there is an electrical switch/interlock on the brake that needs to be made before the shift knob can be moved. The car won't start w/o the brake being pressed, is there a separate switch for the shift knob? I did read on a different thread something about the secondary battery having something to do with the shift knob. My secondary battery has been out of commission for a while when my Eco Start/Stop stopped working.

Any insight or help would be much appreciated.

Thank You
Hello
Did you ever solve the issue with being stuck in D
Please let me know and what was the problem
Thank you
 

Registered
Joined
57 Posts
I had that happen to me shortly after we had purchased our 2014 Evoque Pure Prem. I called JLR right away and while talking to them, I turned off the engine, waited for ten seconds, then turned it on again. In my case, that worked. They saw the fault the next time I had it in for service, but since it hasn't re-occurred in eight years, not a problem. I hope you are successful in fixing the problem.
 
1 - 12 of 12 Posts
Top