Evoque Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Has anyone else had issues with their 2019-2020 Evoque stalling when coming to a stop? This seems to happen at completely random intervals regardless of whether the auto start/stop is on or off. When the car stalls "Select Gear to Manuever" is displayed for about one second on the dash and the "D" flashes with a beeping tone. This has happened to over 20 times in less than 1000 miles! The dealer claims to be unable to replicate the problem or find any error codes even though I have captured it on video. The ignition must be turned off and the car restarted in order to move again. I have seen Discovery Sport Forums describing a very similar issue, but they were all the previous generation with the dial selector vs the current stick selector and no mentions on the Range Rover forums. I have taken the vehicle in twice for repairs with no improvement. I have contacted Land Rover Corporate, but they haven't been very helpful either....
 

·
Registered
Joined
·
2 Posts
Has anyone else had issues with their 2019-2020 Evoque stalling when coming to a stop? This seems to happen at completely random intervals regardless of whether the auto start/stop is on or off. When the car stalls "Select Gear to Manuever" is displayed for about one second on the dash and the "D" flashes with a beeping tone. This has happened to over 20 times in less than 1000 miles! The dealer claims to be unable to replicate the problem or find any error codes even though I have captured it on video. The ignition must be turned off and the car restarted in order to move again. I have seen Discovery Sport Forums describing a very similar issue, but they were all the previous generation with the dial selector vs the current stick selector and no mentions on the Range Rover forums. I have taken the vehicle in twice for repairs with no improvement. I have contacted Land Rover Corporate, but they haven't been very helpful either....
Just purchased a 2019/2020 been driving it for about 10 days and this has happened twice, the first time I thought I was losing my mind and the second time I knew exactly what to do. Haven't called the dealer yet and just wondered if you have heard anything back or have any updates.
 

·
Registered
Joined
·
38 Posts
Mine turns off every time I stop, but I’m pretty sure it’s supposed to 🤔
 

·
Registered
Joined
·
1 Posts
I am having the same issue with my 2020 evoque. I only have 1800 miles. This has happened to me at least 5 times. I have an appointment to bring it in for maintenance on Saturday.
 

·
Registered
Joined
·
1 Posts
Got my wife this car in April, this exact thing has happened 5 times, we called the dealership, they said the key battery might be low, we used a different key, same thing happened. My wife's sister got the same car 2 weeks ago, same thing happening to her, Dealership told them there is nothing to fix. I have an appointment on July 3rd, so we'll see what they say
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Just purchased a 2019/2020 been driving it for about 10 days and this has happened twice, the first time I thought I was losing my mind and the second time I knew exactly what to do. Haven't called the dealer yet and just wondered if you have heard anything back or have any updates.
So, they never intentionally fixed the problem, but after several times back and forth to the dealership they finally installed a data-logger into the car. The found that the ECM did not have the correct software installed and was not communicating with the ECU. Once they reflashed the ECM, I have no more stalling issues. Now....my check engine light is on for a failed evaporator control module...been waiting two weeks for the new one to come in.
 
1 - 7 of 7 Posts
Top