Evoque Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
I wanted to post all my Evoque issues so potential new owners can evaluate for themselves if this is the kind of car you want get involved with.

After one year of ownership and approximately 6,000 miles, the transmission went out. It took over two weeks to diagnose and repair.

After two years of ownership and approximately 12,000 miles, I had other significant issues which I will not mention.

The last issue mentioned was a little over a month ago.

Today, the auto tailgate broke and it won't go up.

The only good thing here is that my local dealer is fantastic and top notch. I just wish the fine folks at the dealership handled a different brand. I'm going to miss the care and professionalism they've provided.

For me, this has been the worst two year car experience i've ever had with a new car bar none. I've owned, several new cars covering a lot brands and none have come close to this.

In baseball terms, 3 strikes and your out!

Land Rover, I hope you are reading this... you have quality issues! Some of them have the potential to cause serious injury or death.
 

·
Registered
Joined
·
242 Posts
Not all of us are disappointed in the reliability of our Evoques. I own a 2013 coupe with 24,000 miles. Only a couple minor issues all this time. The rear light units and one front fog light had to be replaced because of water condensation ( I exchanged the old taillight units with the dealers new ones and replaced them myself, 20min., the dealer replaced the front fog). Unique to the coupe was the sticking front seat back handle releases, seat back frames replaced by the dealer. All this is warranty work. My apprehension is when out of warranty what possible future repairs may cost. The actual price for the one fog light, had it not been warranty, is $600.
 

·
Registered
Joined
·
1 Posts
I feel your pain. 2015 pure premium coupe, where do I begin.

passenger door molding clips weren't installed
rust embedded in tailgate and doors....JLR tells me its environmental but yet the same spots keep reappearing.
3 bolts missing from turbo to bolt to engine....this caused random shutdowns coming slowly to stops....would shut off, be stuck in drive and display "general program not available" 4 times this happened
Turning quickly into a tight parking spot the car will turn itself off and shift to park....20+ times now and this is with eco off and seatbelt buckled.
center touch screen crashes randomly....up to about 12 times now....it stays lit up with the screen but reacts to nothing and stays on after shutting off the vehicle.
wind noise leaking into side windows, creaks and rattles, a 17 speaker system that sounds great but the door panels vibrate so bad it sounds like the speakers are blown.

I did a buyback eval with JLR and they said none of the issues affect driveability......my next step when I have time is to contact lemon lawyer.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Now that i've gotten rid of it, i'll share more.

The power brakes had a sudden catastauphic failure while driving. I'm lucky it happened when it did because if it had happened thirty seconds prior it likely would have been a disaster because I was traveling at highway speeds.

Land Rover didn't give a shit. The dealer did.

Not once did Land Rover contact me during this ordeal.
 

·
Registered
Joined
·
1 Posts
bought In Delaware and the worst dealership I have ever dealt with, registered in PA so have a lemon law lawyer here.....now the transmission has started the 6 click/knock on takeoff from a stop.... I bought my dream car and it has been nothing but a nightmare....the Chinese "land wind" version is probably better quality at this point
 
1 - 8 of 8 Posts
Top