Evoque Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
My car is a 13 evoque with 8k. I was driving to work yesterday and all of the sudden all my dashboard goes out. The car was still driving normal.
After about 5 minutes it came back on. Then a few more miles it did it again. Got to work, drive it home it seemed fine. This morning I go outside and my car wont start. I tried putting the key under the column and still nothing. The dashboard wont light up either but the top light comes on..I was warned
about electrical problems and here we go:(
 

·
Registered
Joined
·
20 Posts
Discussion Starter #2
I'm Thinking about disconnecting the battery and maybe this will reset the computer. Anyone who if this is a good idea or have any suggestions?
 

·
Registered
Joined
·
373 Posts
Think about disconnecting the battery and throwing it away. Seriously, sounds like a bad battery. Have you had it checked? When I bought my 2013 dealer did a load test on the battery and chucked it. Gave me a new one. I have an Si4, but have been hearing diesels are worse for batteries going south.
 

·
Registered
Joined
·
1 Posts
I am seeing the same problem this morning with my Evoque Dynamic 2015. Last night the lights on the dash turned off while driving and I returned home. I turned off the car and trying to turn back on but it doesn't start at all. I called LandRover Roadside assistance as it is still under warranty they are going to come tow it to the dealership to check it out. But I am curious to find out if anyone happen to got this problem figured out?
 
1 - 5 of 5 Posts
Top