Evoque Forums banner

1 - 20 of 41 Posts

·
Registered
Joined
·
4 Posts
Hi, I have changed timing chain on my 2011 pure drive rangerover evoque si4 and remove crankshaft position sensor without mark theposition, now I have loose the good position and my car show error code p0016and p0017, please somebody can say me what tooth fact face to crank sensor whenthe engine is on TDC thx
 

·
Super Moderator
Joined
·
564 Posts
Lasha, Welcome to the forum! I edited your post to change the font color to white, so it was more readable.

Sounds like you are in a bind, sorry for that. You need to get a service manual for the Ford 2.0 EcoBoost engine. After market service manuals for a Range Rover Evoque are hard to find. A Ford manual might be easier to come by.

Good luck!
 

·
Super Moderator
Joined
·
564 Posts
Lasha, I have sent you an e-mail with the procedure from the Range Rover factory service manual, on how to install the crankshaft position sensor.

Let us know how you make out.
 

·
Registered
Joined
·
2 Posts
Good day. Its my first time on this forum. I also need some assistance. I have a Range Rover Evoque si4 and have removed the crankshaft position sensor without marking the position of the tooth on the trigger wheel that is facing the CKPS. After I removed I noticed that the sensor has a slot instead of a hole. Please advise on how to adjust the sensor as I am now getting a P0017 camshaft and bank 1 camshaft correlation error code.

Please assist

GTkhali
 

·
Super Moderator
Joined
·
564 Posts
GtKhali, Welcome to the forum.

If you PM me your e-mail address I can send you some pictures and a write up from the Factory Service Manual on how to correctly install the Crankshaft Position Sensor. You do need a special tool. I have seen the JLR-303-1595 Alignment tool, Crankshaft Damper, advertised for around $50.00.
 

·
Registered
Joined
·
2 Posts
GtKhali, I sent you an e-mail with the procedure for installing the crankshaft position sensor.
Hi Everyone. This is also my first time on this forum. Similar to the rest I also need some assistance from everyone. I just purchased a Range Rover Evoque Si4 with a P0016 & P0017 error too and the previous owner told me that he had changed the pulley before and then these fault codes came out.

Can anyone here help me out please?
 

·
Super Moderator
Joined
·
564 Posts
Super2ndgen, Welcome to the forum!

If you want to PM me your e-mail address, I will forward the e-mail I sent to GtKhali with sections of the Factory Service Manual, for installing the crankshaft pulley. If you need to reset the crankshaft pulley, you will need a Land Rover special tool, which is listed in the e-mail.
 

·
Registered
Joined
·
2 Posts
Super2ndgen, Welcome to the forum!

If you want to PM me your e-mail address, I will forward the e-mail I sent to GtKhali with sections of the Factory Service Manual, for installing the crankshaft pulley. If you need to reset the crankshaft pulley, you will need a Land Rover special tool, which is listed in the e-mail.
Thank you so much Rsquared, my email address would be [email protected]

Your help is greatly appreciated
 

·
Registered
Joined
·
4 Posts
Hi, need help. After camshaft sprocket replacement P0016 is coming back. car running fine, just engine check light coming back.
Is there any special procedure to reset P0016 ?
Initial problem was broken camshaft sprocket and pin. Car was running, but with big performance issues. codes p0016, P0017 and P052A.
My mechanice got parts and tools for dealership, replaced, but P0016 is coming back.
View attachment 3242
After fix
View attachment 3250
Broken

Your help appreciated.
ps.
First post - picture pretty big
 

·
Super Moderator
Joined
·
564 Posts
First, welcome to the forum!

Did the main crankshaft pulley have to be removed to facilitate the camshaft sprocket replacement? If so, there is a special procedure to align the crankshaft pulley with the crankshaft position sensor. The crankshaft position sensor, and the camshaft position sensor, have to be precisely timed together. If they aren't, a P0016 code can be set.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #17
hi, I am tired with my 2011 range rover evoque si4, I have been repearing it for about an year and still din`t finish it. I have changed everything in the engine (beginning from chain to crankshaft position sensor, also phaser), but the CHECK ENGINGE light on the display is stil on. It shows error code p008A (low fuel pressure in the system) code and after sometimes (rarely) also appears p0017 code. We took fuel pump from tank and it works good, then we replaced fuel filter, changed high pressure pump, fuel pressure sensor and still error codes coming on. I can`t find a solution, the worst fact - LAND ROVER CENTER TBILISI also can`t find the solution about the case.

 

·
Super Moderator
Joined
·
564 Posts
I have sent you an e-mail with parts of the service manual, for aligning the crankshaft pulley with the crankshaft position sensor.
 

·
Registered
Joined
·
4 Posts
Rsquared, thanks for your help. I have confirmed with my mechanic, he followed the procedure as per manual (he is using All Data manual) and used special tool set from LR dealer. the code P0016 still there. There is NO performance issue or any other problems.

Any other idea , what could be behind the P0016 ?
 
1 - 20 of 41 Posts
Top