Evoque Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
On my previous Evoque (2015 Dynamic) the speedo went red when I was in Sports Mode and I got into it by moving the gear selector to S and moving the Terrain Response.

Now, I've got a 2018 Dynamic and can't work out how to select Sports Mode. I can put the gear selector to S so no problem there but the Terrain Response bar doesn't go any further left than the General Terrain icon although my manual does show the double squiggly line (technical term).

Whatever I try doesn't light up the speedo in red or any other colour so am I missing a button or something?

TIA.
 

·
Registered
Joined
·
81 Posts
I believe from the 2018 model the dynamic mode was a paid option, even on the dynamic model. It sounds like yours doesn’t have that mode.
I have a MY20 R-Dynamic and that doesn’t have dynamic mode.
 
1 - 2 of 2 Posts
Top