Evoque Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Just installed the factory towing drawbar and put a nice Yakima Holdup hitch rack for my bikes. Everytime I back up now though with the rack on, the parking aids beep and I have to hit the button to turn them off. I cant remember how to go into the detailed setup menu to turn this off.

Also, if anyone needs help on how to install the towbar, I can help. The instructions are absolutely ridiculous. If you dont have any autmotive experience, you will not likely figure it out. The first instruction picture has the entire rear bumper and panels shaded with arrows pointing down and a picture of a piece of paper with text on it ( guess that means service manual?.) Thats their way of telling you how to take the entire bumper off. There are some tricks to it, I wished I would have filmed it so I could put it up on youtube.

Thanks!!
 

·
Registered
Joined
·
46 Posts
Basic Forum Rule # 3B: Without Pictures, it never happened....
We need to see the rack with bikes, mounted, at the very least. :cool:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Basic Forum Rule # 3B: Without Pictures, it never happened....We need to see the rack with bikes, mounted, at the very least. :cool:
I was thinking the same thing after I posted this. I'll gladly take some pictures tomorrow to post! I've been lurking around here since I bought my Evoque in March but haven't had anything to add so far.
 

·
Registered
Joined
·
46 Posts
Excellent!! Great pics, good job. Thanks for showing that off :cool:
 

·
Registered
Joined
·
1 Posts
is the original hitch for the Evoque size 1 1/4" as the standard or is it a custom size from Land Rover? does it fit the yakima holdup 1 1/4"
 
1 - 7 of 7 Posts
Top