Evoque Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
The 2014 has 49k and the warranty gig is up at 50,000. Planning to take it in soon for an alignment and get the computer updated but what else should I have the dealer do or look at? The only thing I have had go bad was a fuel rail sensor a couple years back. Any tips or advise would be appreciated.
Thanks
JD
 

·
Registered
Joined
·
171 Posts
Any exhaust smells in the cabin? It seems that all of the exhaust manifolds crack between 50k and 90k miles. I also had a small leak on the lines that attach to the transaxle, but they said it wasn't enough of a leak for them to do anything about it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
So far no exhaust in the cabin but that's my luck. I need to research the turbo as well so i'm ready when it dies. My appointment is set up for next week. 50k service and an alignment.

JD
 

·
Registered
Joined
·
171 Posts
I just posted that the other day. I get in mine this afternoon and the whirring sound I usually hear from the turbo is gone and instead is a much different sound and I have much less power. I put on my code reader and see that I am making no boost at all. So unless I have some air leak in the hoses (so far I don't see any) it looks like my turbo has failed at 52k miles. Unlike others on here, I am not smelling any exhaust fumes. It seems many crack up close to the block and you smell the fumes. I think mine is cracking like this guy explains in the video:


The only think is he describes it as the turbine lodging and not being able to spin. But I am definitely still hearing something happen. So maybe I have some other problem.
 
1 - 4 of 4 Posts
Top