Evoque Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I got a 2014 Evoque Dynamic in December 2013 (Firzenze Red, Black Roof). Beautiful car, however I keep having issues with it. After a year, I do qualify to get the car purchased back under the lemon law already…. As much as I really would like to keep the car, it has been too unreliable and I am losing patience (as of today, the car has been at the dealer more than 30 days within 13 months!). Out of curiosity, did anyone get their car bought back by Land Rover under the lemon law? How cooperative Land Rover is on that matter?

If you are interested, this is the list of issues I faced so far…

March 2014 (at the dealer for 5 days):
Engine light on - defective O2 sensor replaced
Sunroof switch rattles – fixed. For about a week, then it started rattling again
Park exit function not available - unresolved - software not available at that time
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved

June 2014 (at the dealer for 3 days)
Recall Q437 Park Exit function - resolved
Sunroof switch rattles – could not fix then - ordered replacement part
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved

September 2014 (at the dealer for 4 days)
Replaced sunroof switch console - resolved
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved
Cracking sound from right front A pillar - unresolved
Q400 Software update to production level

November 2014 (at the dealer for 8 days)
Recall Q425 9 speed automatic transmission calibration
Recall Q409 Engine Light Illumination
Recall Q406 Gateway Module Software Update
Cracking sound from right front A pillar - fixed
Left rear window - does not go automatically up - resolved
Eco start/stop not working – fixed, for about a week, then stopped working again
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved

February 2015 (at the dealer for 6 days)
Eco start/stop not working – replaced battery, updated software. Still did not fix the issue
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – updated software – still did not fix the issue

When I went to pick it up last week, none of the two issues I brought the car for were not fixed! Then the service manager mentioned that there is (yet another) software recall (Q450) to supersede the previous transmission calibration (Q425). I do not have much hope that it will fix the issue but you never know…

In the meantime I am still driving the loaner...
 

·
Registered
Joined
·
173 Posts
When I was at the dealer the other day, I asked about their buyback options. Service advisor said it had to be in the shop for 3 times or more. California Lemon Law is fairly specific- although there is a "must affect the use, safety....... " clause so that's a little subjective.

Definitely worth a call or email to LR corporate to ask them for a buyback.
 

·
Registered
Joined
·
76 Posts
I hate to be that guy, but most of your "problems" are far from being serious enough for a buy back. I have to address them all:

I got a 2014 Evoque Dynamic in December 2013 (Firzenze Red, Black Roof). Beautiful car, however I keep having issues with it. After a year, I do qualify to get the car purchased back under the lemon law already…. As much as I really would like to keep the car, it has been too unreliable and I am losing patience (as of today, the car has been at the dealer more than 30 days within 13 months!). Out of curiosity, did anyone get their car bought back by Land Rover under the lemon law? How cooperative Land Rover is on that matter?

If you are interested, this is the list of issues I faced so far…

March 2014 (at the dealer for 5 days):
Engine light on - defective O2 sensor replaced Fixed.
Sunroof switch rattles – fixed. For about a week, then it started rattling again Good luck getting a rattle to count as major problem.
Park exit function not available - unresolved - software not available at that time Legit issue. LR must fix.
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved Shakes noticeably? What does that mean? Shifting gears is noticeable in any vehicle.

June 2014 (at the dealer for 3 days)
Recall Q437 Park Exit function - resolved So far your one legit issue is fixed.
Sunroof switch rattles – could not fix then - ordered replacement part Please don't tell me you want Lemon Law because of a rattle.
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved Gearboxes do this.

September 2014 (at the dealer for 4 days)
Replaced sunroof switch console - resolvedo Well there goes your chance for Lemon buy back due to a rattle!
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved Yep, still working like a gearbox.
Cracking sound from right front A pillar - unresolved A cracking sound!? Oh my, how did you manage!?
Q400 Software update to production level This is actually a good thing.

November 2014 (at the dealer for 8 days)
Recall Q425 9 speed automatic transmission calibration Yay!
Recall Q409 Engine Light Illumination Yay!
Recall Q406 Gateway Module Software Update Yay!
Cracking sound from right front A pillar - fixed Yay!
Left rear window - does not go automatically up - resolved Yay!
Eco start/stop not working – fixed, for about a week, then stopped working again Probably user error/misunderstanding. Eco only functions in ideal temperatures/situations.
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – unresolved OK, this is obviously a big deal to you and so far the only "issue" unresolved. If it's that serious then this should be your main focus. Explain further what is happening. If you're just irritated by the feeling of a shift then you're SOL. If it's shifting so hard it's spilling boiling hot coffee on your crotch then maybe you've got a legit complaint.

February 2015 (at the dealer for 6 days)
Eco start/stop not working – replaced battery, updated software. Still did not fix the issue Still putting my money on user issue.
Gearbox shakes noticeably when upshifting from 2[SUP]nd[/SUP] to 3[SUP]rd[/SUP] – updated software – still did not fix the issue See last comment on this.

When I went to pick it up last week, none of the two issues I brought the car for were not fixed! Then the service manager mentioned that there is (yet another) software recall (Q450) to supersede the previous transmission calibration (Q425). I do not have much hope that it will fix the issue but you never know... Actually you will, ever know. Have the update done and report back. It very well may fix your issue. I have a 2014 with all recalls/updates done and my Evoque works peachy.

In the meantime I am still driving the loaner...
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Thanks for taking the time to reply. We are getting a little off topic here but I will also spend the time to reply here.
- the hard shifting betwewen second and third gear is not just me being picky. As a matter of fact, I had the service manager drove the car with me last time, and he acknowledged the issue the minute we left the parking lot. It is a very noticeable shake.
- the eco start/stop not working was not just a "user issue". I live in FL where the weather is very consistent, and I do understand that the car will not turn off every time I stop, however, I am talking about the car not stopping at all anymore (under any condition, engine warm or not, temperature ranging from 50F to 90F, with or without the AC, whether driving 1 mile or 200 miles straight). This got fixed once and stopped working again after; the second time it got fixed, I just got the car back, we will see if it lasts
- I am not planning on claiming the lemon law because of a switch rattling... In my state, I would qualify either under the number of days out of service (more than 30), or under the condition of having the same issue not repaired after three attempts (either case works for me at that point). Do not get me wrong, I love this car and would rather have it fixed, but it does not seem that they are getting anywhere with the transmission (the Q425 recalibration did not help, and I just got the Q450 recalibration, and I am still having the same issue-although the dealer told me that I have to drive the car more than 200 miles for the tranmissions to reconfigure itself, which i have not done yet).

So, yes I love this car, but getting the same issue unresolved over and over gets old quickly... Back to my original question, anyone had any experience with LR regarding the lemon law?
 

·
Registered
Joined
·
25 Posts
I have to agree with HJT113 - For as much as these cars cost, we shouldn't be at the dealer EVERY month with issues and software updates. My dealership is an hour away and I work 5 days a week. I had to have mine TOWED two weeks ago because it died on the freeway (apparently a high-pressure fuel pump). This after several trips and 500 miles driven by the Engineer to figure out why it chugged consistently when driving freeway speed of 70. He ultimately replaced the fuel injectors and said it was California gas. (!!) Really? So, should I MOVE? Or call Chevron up and tell them their Premium gas at nearly $4 a gallon is crap? This is only a small example of the issues I've had on my 2012 Prestige. $52,000 not well spent.
 

·
Registered
Joined
·
518 Posts

·
Registered
Joined
·
335 Posts
Geez I wish my start/stop feature would fail! Annoying being stop for 2 seconds at stop only to have engine shut off. I'm looking into getting the eco button reversed. My economy is driving an Evoque instead of a big Rangie. I don't care about the .1-.2 mpg these features give me. The other blatant failures are surprising. Motor related issues are Ford! I wonder what percentage of owners are having issues seen as this forum has next to NO participants? JD Power has had Jag at or near the top for years now. Is Range Rover that different? My 2 XJ's NEVER once paid a visit back to the dealer. I just did the routine maintenance.
 

·
Registered
Joined
·
77 Posts
They've been trying to get my start/stop to work again on my MY2014 since May 12th. It stopped working sometime over the winter. They've checked software replaced modules etc etc. Loaner works perfectly. I doubt the OP's issue is user error.
 

·
Registered
Joined
·
335 Posts
People really care about that annoying eco BS?? If you knew how little it really does unless in daily LA or NYC traffic you'd laugh. The added weight of a second battery???
 

·
Registered
Joined
·
77 Posts
I almost didn't bother mentioning start/stop to them when I brought it in for service. Totally wouldn't have bothered if it wasn't under warranty. This is about the third time I've had them look at something that ended up taking WELL over a week. Like the park exit feature, which apparently hadn't been properly set up for the US Evoques and resulted in LR having to fix their software and issue a recall on it.
 

·
Registered
Joined
·
335 Posts
Sounds like a clueless dealer. Dianose, give car back and have it return when parts arrive. NO ONE keeps any car of mine for a week. EVER!
 

·
Registered
Joined
·
76 Posts
1 - 13 of 13 Posts
Top