Evoque Forums banner
21 - 40 of 41 Posts

·
Registered
Joined
·
6 Posts
Alas I had to cancel the appointment (my fault, not LR's) so they haven't been able to upgrade the software yet. I plan on trying to reschedule the appointment but it probably won't be for a couple of weeks.

In the meantime I'd encourage anyone experiencing this issue to switch the TV region from UK to US. This most definitely kills the static and allows for the other systems in the car to be used as intended. You'll lose the use of your TV until the matter is resolved by LR properly but I suspect that the TV is not the most important feature to the majority of Evoque drivers.

In response to any LR dealer that thinks this isn't a safety issue, I'd point out that it's far from ideal to be losing audio half way through a sat nav command.
 

·
Registered
Joined
·
3 Posts
I to have they same problem. Thankfully I am not alone with this issue as it is difficult to explain to the garage. It started approx 2 months ago. At first it was just the odd crackle, now as well as the crackle the radio/cd/mp3/sat nav all drop out for a brief moment. One of the blogs mentioned that there is now a software fix from LR. I will go to the LR dealer on Monday 30/9/13 and see if that's the case. Will let all know Monday pm..
 

·
Registered
Joined
·
5 Posts
I thought it was my new phone that was causing this so I am pleased that others have the same problem. The change settings to USA TV cured it! Now we need a software update... I did not only get the interference on the speakers but also the Sat Nav screen deselected back to Menu screen a couple of times!
 

·
Registered
Joined
·
5 Posts
Well, after setting the tv back to UK and a short test drive it would appear that this was the answer. (setting the tv to usa). The faults are back. The audio crackles and the Sat Nav resesets itself!!! so back to tv to USA!!
 

·
Registered
Joined
·
46 Posts
The US "borrows" many of the UK's television shows anyway. The Office is one of my favorites, and Downton Abby is extremely popular too although there is no US remake at this time. Stay away from anything "Kardashian" though, that will rot your brain...

Just kidding, (not about the Kardashian stuff though, that crap is horrible) I hope they figure out the problem and come up with a permanent fix. That has to be frustrating. Out of curiosity, how often do you use the TV function? I had not heard of this option until there was a problem brought up on this site. I had a couple of family haulers with the DVD rear entertainment option before, but we rarely used it, not enough to justify getting it again anyway. Now with the advent of tablet computers, iPods, and other portable electronics, the kids manage to entertain themselves with games and the like for long trips.

Rob
 

·
Registered
Joined
·
74 Posts
The US "borrows" many of the UK's television shows anyway. The Office is one of my favorites, and Downton Abby is extremely popular too although there is no US remake at this time. Stay away from anything "Kardashian" though, that will rot your brain...
let's not forget the popular BBC America TV channel, which keeps me supplied with my Top Gear requirements (and which I blame for catching my attention with their Evoque segment).
 

·
Registered
Joined
·
46 Posts
I forgot all about that one. The US has a version of that show too. The UK version is better than the US version of Top Gear, US version has too many "scripting" that is too far fetched to be anywhere close to believable and little to no real car information. Sorry to the folks that have the radio/entertainment system issue for going off topic.

Rob
 

·
Registered
Joined
·
3 Posts
I to have they same problem. Thankfully I am not alone with this issue as it is difficult to explain to the garage. It started approx 2 months ago. At first it was just the odd crackle, now as well as the crackle the radio/cd/mp3/sat nav all drop out for a brief moment. One of the blogs mentioned that there is now a software fix from LR. I will go to the LR dealer on Monday 30/9/13 and see if that's the case. Will let all know Monday pm..
Have now been in touch with Satna at Customer service Land Rover tel. 01926 691851 she informs me she received an e-mail 25 Sept from manufacturing that they are hoping to have a fix within 2 weeks. She is calling me back Fri 4th. Will keep all updated. It might pay all fellow Evoque owners with this problem to contact LR on the number I have listed............
 

·
Registered
Joined
·
1 Posts
Crackling Sounds (Static) from Speaker

Have you had any luck. We are having the same problem and the car was in for another software update due to an alarm issue today. We have been told that this radio/frequency software does not exist by the dealer in Derby and also Land Rover CS. Did they upgrade your software and did it work? Any idea what the update is called?
Thanks for your help.
Mark
I have the exact same problem. The static sound comes even with the radio (Audio) switched off. The crackle is followed by silence for 2 seconds or so. I called the dealer today and they told me that there is no official fix from Land Rover at the moment but like others in this string of responses, I was told to change the TV to United States. This seems to have worked but this is hardly a fix. Breaking one thing to fix another is not what we are after. Nevertheless, the elimination of the irritating crackle takes precedence over watching the TV in the car. What about those who do not have the TV tuner? Are they having the same issue? If so, what is the workaround for them?
 

·
Registered
Joined
·
2 Posts
Have also had this problem, have cured it temporarily by turning the tv setting to United States, this stops the intermittent crackling noise, only problem is you cannot watch tv until you turn it back onto UK. Have a one year old Prestige Lux
 

·
Registered
Joined
·
5 Posts
Had a chat with my dealer and it was explained to me that any vehicle fitted with a Lear TV receiver has the problem as it can not handle the new number of Freeview channels. When it picks up more than it can handle it thinks it is a fault and resets. This causes things like the Sat Nav to reset (and I had a camera output turn to a big red cross). Landrover are in talks with Lear to get a fix. It may be a new console! if software can not do it.....
Here is a short video of the screen resetting. The crackle is not so load on the recording..
 

·
Registered
Joined
·
3 Posts
Had a chat with my dealer and it was explained to me that any vehicle fitted with a Lear TV receiver has the problem as it can not handle the new number of Freeview channels. When it picks up more than it can handle it thinks it is a fault and resets. This causes things like the Sat Nav to reset (and I had a camera output turn to a big red cross). Landrover are in talks with Lear to get a fix. It may be a new console! if software can not do it.....
Here is a short video of the screen resetting. The crackle is not so load on the recording..

L/R did not reply on Friday as promised. I'll wait a couple of days and try again. I'm sure if it was a software fix we'd have had it by now. Looks like it's a costly job for L/R , and I'm sure they'll drag their heels
 

·
Registered
Joined
·
6 Posts
Finally managed to take the Evoque into Land Rover Hunters of Southampton today. They received a software fix for the TV tuner issue late last week and upgraded the software on my Evoque this morning. Touch wood it's been fine for the rest of today.
 

·
Registered
Joined
·
3 Posts
Mirror

I had my evoque into the shop again for the static. While I know the tuner issue in the UK seemed to be a software fix. My issue was fixed with a mirror replacements . Don't know how or why but when I retracted the mirrors the static noise went away. They replaced my passenger side mirror and it seemed to fix the problem. Again I don't know how they narrowed it down to that as the issue .
 

·
Registered
Joined
·
2 Posts
Evoque had its first service last week, the service dept carried out a software update and now the crackle has gone, let's hope it's lasts.
 

·
Registered
Joined
·
8 Posts
Hello to everyone here. It seems like this thread has gone a bit quiet for a few months. I live in what Jeremy Clarkson calls the colonies & I'm having the static issue with the Evoque. We don't have a tv tuner over here so switching that is not an option. Are the software updates working now. The dealer service centers I speak with about this issue act clueless about it.
 

·
Registered
Joined
·
5 Posts
Static noise and software update

Hi,
The static type noise was caused by the TV tuner (which is always on and searching for channels when the ignition is on) finding more channels than it could cope with. This made the unit think it was faulty and so it reset itself. This included the sat nav and audio systems. This caused the static type noise. The TV system was selected to receive UK Freeview digital television and the maximum number of channels it could cope with was around 50. When the number of channels increased to 100+ the problem started across the country on many makes of car that used the same entertainment system. The quick fix worked - selecting USA as your region - but you could not watch TV. The software upgrade cured the problem and now the TV tuner can cope. This was a complete cure for that fault.
If you have a similar problem with audio static but no TV tuner then it is not this problem, however it could be the entertainment system resetting and that can be seen by checking the sat nav. If the static noise happens due to a reset then the sat nav also resets. I tried to show this on this video
Martin
 

·
Registered
Joined
·
4 Posts
At highway speed I noticed what sounded like radio static sounds. As it turns out it was the left and right pillar covers. Some of you might be having the same issue. If you grip the pillar covers in your hand and wiggle them, you might notice a scratching sound. I just had mine replaced at the dealer.
 

·
Registered
Joined
·
10 Posts
THis thread is totally quiet since 2014 for some strange reason but I just purchased a 2014 Evoque here in the states and have the static issue and no tv tuner. Has anyone gotten a fix for their static in the USA?
 

·
Registered
Joined
·
5 Posts
You can try and get a service update or the other thing is to select another country for the tv tuner. That is if it is the software problem. In the UK it was caused by the digital TV transmission system increasing the number of transmitted channels above 99.and the old software in the TV tuner only able to receive upto 99 different channels. When it saw more it thought it was a fault and reset every few minutes. Changing to a different country means it will not pick up a signal on the TV but the system will not reset itself. Hence not crackle. The other thing it did if that is the fault you have is the navigation resets at the same time.
 
21 - 40 of 41 Posts
Top