Evoque Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello everyone,

My rover wouldn’t start and I had a timing code. I removed the valve cover and found that the locking pin on the VVT was broken. From my understanding, this is a somewhat common issue and Land Rover released a service bulletin. My question is, does anyone have information on how to go about replacing this? Thanks!
4666
4668
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thank you for all the great details, Htown! I did try to tackle this job, only because I’m afraid the engine has internal damage and I just wanted to give this a try before replacing the engine. I got the new parts in it and it didn’t resolve anything. My question now is could I replace the engine with a Ford 2.0 ecoboost from a fusion, escape, or other models? Or would it have to be from a Land Rover? The motor in my car says “FoMoCo” everywhere and appears to be the same engine as the Ford vehicles.

Thanks again!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Well, I planned on doing the job correctly. I purchased the timing tools and took my time, however about half way in it started going poorly. I couldn’t get the camshafts to align and ended up breaking the cast iron end of the back one. That piece then fell in one of the cylinders. It wouldn’t stick to a magnet because it was cast iron and I couldn’t retrieve it. At that point I decided I’d just put it back together and see what happened, because I figured it needed an engine anyway. I didn’t take the axle off to insert the remaining timing tool either. The car tried to turn over, but I believe the engine is locked. When I try to start it, it will short out the starter. I can take the starter out and reconnect the wiring, but I happens again.
 
1 - 3 of 3 Posts
Top