Evoque Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have the P0299 underboost code that keeps coming back. I changed the turbo out but it keeps coming back. The car is boosting but drops out in boost on higher acceleration. Checked for leaks from the turbo to the intake manifold and found that there is some air leaking from the tube connecting the intake manifold to the air filter inlet piping. Is there anything else that is common for this to bring in the code? Any help is greatly appreciated as I have been at this for a few months now.
 

·
Registered
Joined
·
14 Posts
Underboost is caused by leaks from the charge pipe into the intake, vacuum leaks, blowoff valve/bypass valve or wastegate malfunction, wastegate actuator malfunction, or sensors not functioning well and causing the computer to have “false” input which in turn causes the computer to adjust intake and fuel accordingly.
Visual inspection, smoke test for leaks, track live data while accelerating, and use a picoscope as needed on sensors to help diagnose The cause.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I took it to a shop. They couldn't find any leaks or any trouble as well. I seem to have good boost when the temperatures are cooler at night. When the Temps get hot it loses boost. I can hear it wasting into to back somewhere. Maybe the purge valve malfunctioning or something with the emissions system.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I am thinking that it maybe the vapor purge valve. It shows operational on the scanners but I think it may be leaking through. I will change the part soon and update of that was the fix. I called the dealer and its around 160 for the unit and hoses as one.
 
1 - 8 of 8 Posts
Top